Bug 441508 - BUG kmalloc-32 (Not tainted): Object already free (kernel-2.6.25-0.201.rc8.git4.fc9.i686)
BUG kmalloc-32 (Not tainted): Object already free (kernel-2.6.25-0.201.rc8.gi...
Status: CLOSED DUPLICATE of bug 441133
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 11:00 EDT by Tom London
Modified: 2008-04-17 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 22:29:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-04-08 11:00:55 EDT
Description of problem:
Running on Thinkpad X60 (intel 945 graphics), Rawhide.

Got this when shutting down:

Apr  8 07:31:27 localhost kernel:
=============================================================================
Apr  8 07:31:27 localhost kernel: BUG kmalloc-32 (Not tainted): Object already free
Apr  8 07:31:27 localhost kernel:
-----------------------------------------------------------------------------
Apr  8 07:31:27 localhost kernel: 
Apr  8 07:31:27 localhost kernel: INFO: Allocated in drm_addmap_core+0x29/0x4be
[drm] age=4439438 cpu=0 pid=2581
Apr  8 07:31:27 localhost kernel: INFO: Freed in drm_rmmap_locked+0x140/0x14a
[drm] age=11073 cpu=1 pid=2581
Apr  8 07:31:27 localhost kernel: INFO: Slab 0xc1b87050 used=9 fp=0xf4b262d0
flags=0x40000083
Apr  8 07:31:27 localhost kernel: INFO: Object 0xf4b26820 @offset=2080 fp=0xf4b26870
Apr  8 07:31:27 localhost kernel: 
Apr  8 07:31:27 localhost kernel: Bytes b4 0xf4b26810:  15 0a 00 00 38 3d 40 00
5a 5a 5a 5a 5a 5a 5a 5a ....8=@.ZZZZZZZZ
Apr  8 07:31:27 localhost kernel:   Object 0xf4b26820:  6b 6b 6b 6b 6b 6b 6b 6b
6b 6b 6b 6b 6b 6b 6b 6b kkkkkkkkkkkkkkkk
Apr  8 07:31:27 localhost kernel:   Object 0xf4b26830:  6b 6b 6b 6b 6b 6b 6b 6b
6b 6b 6b 6b 6b 6b 6b a5 kkkkkkkkkkkkkkk�
Apr  8 07:31:27 localhost kernel:  Redzone 0xf4b26840:  bb bb bb bb            
                        ����            
Apr  8 07:31:27 localhost kernel:  Padding 0xf4b26868:  5a 5a 5a 5a 5a 5a 5a 5a
                        ZZZZZZZZ        
Apr  8 07:31:27 localhost kernel: Pid: 2957, comm: compiz Not tainted
2.6.25-0.201.rc8.git4.fc9.i686 #1
Apr  8 07:31:27 localhost kernel:  [<c048667b>] print_trailer+0x111/0x119
Apr  8 07:31:27 localhost kernel:  [<c0486747>] object_err+0x20/0x2a
Apr  8 07:31:27 localhost kernel:  [<c0487bf7>] __slab_free+0x178/0x265
Apr  8 07:31:27 localhost kernel:  [<c0487ec1>] kfree+0xb3/0xec
Apr  8 07:31:27 localhost kernel:  [<f8d371de>] ? drm_vm_shm_close+0x181/0x191 [drm]
Apr  8 07:31:27 localhost kernel:  [<f8d371de>] ? drm_vm_shm_close+0x181/0x191 [drm]
Apr  8 07:31:27 localhost kernel:  [<f8d371de>] drm_vm_shm_close+0x181/0x191 [drm]
Apr  8 07:31:27 localhost kernel:  [<c0479854>] ? remove_vma+0x48/0x4e
Apr  8 07:31:27 localhost kernel:  [<c047983c>] remove_vma+0x30/0x4e
Apr  8 07:31:27 localhost kernel:  [<c0479915>] exit_mmap+0xbb/0xd6
Apr  8 07:31:27 localhost kernel:  [<c0426897>] mmput+0x3a/0x82
Apr  8 07:31:27 localhost kernel:  [<c042a000>] exit_mm+0xe1/0xe7
Apr  8 07:31:27 localhost kernel:  [<c042b631>] do_exit+0x203/0x5c3
Apr  8 07:31:27 localhost kernel:  [<c042ba57>] do_group_exit+0x66/0x7d
Apr  8 07:31:27 localhost kernel:  [<c042ba81>] sys_exit_group+0x13/0x15
Apr  8 07:31:27 localhost kernel:  [<c0405d2e>] syscall_call+0x7/0xb
Apr  8 07:31:27 localhost kernel:  =======================
Apr  8 07:31:27 localhost kernel: FIX kmalloc-32: Object at 0xf4b26820 not freed
Apr  8 07:31:27 localhost ntpd[11472]: ntpd exiting on signal 15
Apr  8 07:31:29 localhost console-kit-daemon[2344]: WARNING: Couldn't connect to
system bus: Failed to connect to socket /var/run/dbus/system_bus_socket:
Connection refused
Apr  8 07:31:32 localhost kernel: Kernel logging (proc) stopped.



Version-Release number of selected component (if applicable):
kernel-2.6.25-0.201.rc8.git4.fc9.i686

How reproducible:
Don't know

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dave Airlie 2008-04-17 22:29:46 EDT

*** This bug has been marked as a duplicate of 441133 ***

Note You need to log in before you can comment on or make changes to this bug.