Bug 441513 - gnome-packagekit hangs UI hangs when it needs to import gpg signatures
gnome-packagekit hangs UI hangs when it needs to import gpg signatures
Status: CLOSED DUPLICATE of bug 440156
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9PKBlocker
  Show dependency treegraph
 
Reported: 2008-04-08 11:05 EDT by Thomas J. Baker
Modified: 2008-04-19 08:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-19 08:30:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2008-04-08 11:05:51 EDT
I thought I saw this talked about somewhere but I can't find a bug for it.

If I install the livna release rpm and then try to install something from it
using packagekit, it hangs with the status bar displaying "Checking signatures".
It's hung somewhere relating to importing/accepting the livna signature. If I
install something from livna first using yum in a terminal and accept the
signature, then packagekit installs after that are fine.

I'm using 

yum-packagekit-0.1.11-1.fc9.x86_64
gnome-packagekit-0.1.11-1.fc9.x86_64
PackageKit-0.1.11-1.fc9.x86_64
PackageKit-libs-0.1.11-1.fc9.x86_64
Comment 1 Thomas J. Baker 2008-04-18 13:53:46 EDT
I just reinstalled the preview, added the livna repos, and had the same problem.
The app installed would just hang and there was no way to get any information on
what was going on. I then installed a single livna package by hand and it
prompted me for the gpg key acceptance and I remembered this bug.

I'm using these:

PackageKit-0.1.12-4.20080416git.fc9.x86_64
yum-packagekit-0.1.12-4.20080416git.fc9.x86_64
gnome-packagekit-0.1.12-5.20080416git.fc9.x86_64
jpackage-utils-1.7.5-1jpp.1.fc9.noarch
PackageKit-libs-0.1.12-4.20080416git.fc9.x86_64

I would consider this a blocker given the opaqueness of what the problem is and
how friendly the app installed is supposed to be. 
Comment 2 Thomas J. Baker 2008-04-18 16:07:23 EDT
This bug is probably the same as https://bugzilla.redhat.com/show_bug.cgi?id=440156.
Comment 3 Richard Hughes 2008-04-19 08:30:18 EDT

*** This bug has been marked as a duplicate of 440156 ***

Note You need to log in before you can comment on or make changes to this bug.