Bug 441532 - Output of help for ferror is mangled
Output of help for ferror is mangled
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: frysk (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Sami Wagiaalla
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 12:11 EDT by Petr Muller
Modified: 2016-09-19 22:10 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-15 04:45:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Muller 2008-04-08 12:11:41 EDT
Description of problem:
When you try to get help for the ferror command with 'ferror -help', you see 
the output quite badly mangled and badly readable. The problem is that is seems 
that in the line for '-e' option, '--error' and the description for the option 
are switched, which renders first column too long, making the second very 
narrow.

Version-Release number of selected component (if applicable):
frysk-0.0.1.2008.03.19.rh1-1.el5

How reproducible: always

Steps to Reproduce:
1. ferror -help
  
Actual results:
mangled output

Expected results:
nice output
Comment 1 Andrew Cagney 2008-04-08 14:22:26 EDT
Looks to be fixed upstream.
Comment 2 Mark Wielaard 2008-04-10 06:55:11 EDT
It does look like it is solved upstream, but appearances can deceive :) It looks
fixed because the option groups changed, so -e is the only option in its group.
But if you look closely you see that it is still strangely formatted:

ferror options:
  -e error regex to catch in double quotes -e "<error string>"      --error

The real problem is that it was using the wrong Options constructor (wrong order
of arguments. I pushed a fix upstream:

commit 2cadcd56c2fd4e1913739994da28f1f8d1f817a4
Author: Mark Wielaard <mwielaard@redhat.com>
Date:   Thu Apr 10 12:27:05 2008 +0200

    Use correct Options constructor for ferror.
    
    frysk-core/frysk/bindir/ChangeLog
    2008-04-10  Mark Wielaard  <mwielaard@redhat.com>
    
           * ferror.java (options): Use correct Options constructor.

Now it says:

ferror options:
  -e, -error <error string>    error regex to catch in double quotes

Note You need to log in before you can comment on or make changes to this bug.