Bug 441560 - Should mark pam files as %config [NEEDINFO]
Should mark pam files as %config
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-screensaver (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 15:04 EDT by wilburn
Modified: 2014-06-03 08:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:37:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (wilburn)


Attachments (Terms of Use)
Debug output from gnome-screensaver (126.34 KB, text/plain)
2008-04-08 17:15 EDT, wilburn
no flags Details

  None (edit)
Description wilburn 2008-04-08 15:04:48 EDT
Description of problem:

gnome-screensaver makes display unusable since update to
gnome-screensaver-2.16.1-5.el5_1.1

Version-Release number of selected component (if applicable):
gnome-screensaver-2.16.1-5.el5_1.1

How reproducible:
Ever time

Steps to Reproduce:
1. Start gnome session
2. Wait for screensaver to start
3.
  
Actual results:

Moving mouse produces blank screen with only large cursor visible. Unlock screen
never displayed. Typing password anyway has no effect. Can not return display to
normal w/o killing gnome-screensaver.


Expected results:

Unlock screen displayed, display returns to normal after entering password.


Additional info:
My settings are
Screensaver theme: Blank
Regard the computer as idle after: 1 minute (for testing)
Activate screensaver when computer is idle: YES
Lock screen when screensaver is active: YES
Comment 1 jmccann 2008-04-08 16:10:56 EDT
Thanks for the report.  Unfortunately, I'm unable to reproduce this.

Can you please provide us with some additional information?

First, kill off gnome-screensaver: 
pkill -f gnome-screensaver
Then run with debugging enabled and redirect this to a file:
gnome-screensaver --no-daemon --debug > gs.log 2>&1

Then reproduce the problem and attach the gs.log here.

Thanks.

Comment 2 wilburn 2008-04-08 17:15:23 EDT
Created attachment 301714 [details]
Debug output from gnome-screensaver
Comment 3 jmccann 2008-04-08 17:25:28 EDT
Looks like you may be using a remote directory service (nis, nis+, ldap, etc),
right?

I think will occur is you are not connected to the network and are not running
nscd.  If you ensure that you are connected to the same network as your
directory does this still occur?
Comment 4 wilburn 2008-04-09 13:00:08 EDT
You are on the right path. I use ldap for account information, kerberos for
authentication. For reasons that aren't worth explaining, the gnome-screensaver
pam file is modified, rather than system-auth.
gnome-screensaver-2.16.1-5.el5_1.1 replaced the pam file and gnome-screensaver
could not get account information.

Two things for you to consider whether this is a bug or not:
1. Packages usually do not replace modified config files, instead create a
.rpmnew version.
2. Should gnome-screensaver fail in this way when it can't obtain account
information? Seems inelegant.

Thanks for the help!
Comment 5 jmccann 2008-04-09 13:07:00 EDT
Great!  So, you are probably right.  We should mark the pam file as %config so
it isn't replaced.  Thanks for testing this.
Comment 6 jmccann 2008-04-09 13:09:56 EDT
You're also right that we should display a message when this occurs.  But that
isn't something we could do in that security errata.  I've created the following
bug for that:
http://bugzilla.gnome.org/show_bug.cgi?id=527185

Thanks again.
Comment 7 RHEL Product and Program Management 2014-03-07 07:48:02 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 8 RHEL Product and Program Management 2014-06-03 08:37:46 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.