Bug 441565 - ksplashrc: Theme=Waves not working
ksplashrc: Theme=Waves not working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target KDE4Live
  Show dependency treegraph
 
Reported: 2008-04-08 15:29 EDT by Rex Dieter
Modified: 2008-04-12 01:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.0.3-11.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-12 01:51:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2008-04-08 15:29:01 EDT
Summary says it all.
Comment 1 Kevin Kofler 2008-04-08 17:04:42 EDT
The problem is that KSplash is set up using the kstartupconfig4 hack. The 
comment at the top says:

> This utility helps to have some configuration options available in startkde
> without the need to launch anything linked to KDE libraries (which may need
> some time to load).


Those settings are cached using kdostartupconfig4 and then kstartupconfig4 only 
reads them. Does running kdostartupconfig4 to force regenerating the cache fix 
it? The problem is that kstartupconfig4 only checks the files kdostartupconfig4 
wrote into "startupconfigfiles" for updates, and that kdostartupconfig4 only 
writes the files in ~/.kde/share/config there.

I see 2 possible solutions:
a. hacking that kstartupconfig system to understand Kiosk-style settings
b. simply changing the default in startkde in the redhat-startkde patch: 
startkde.cmake contains:
ksplashrc KSplash Theme Default
changing that to:
ksplashrc KSplash Theme Waves
should be enough to fix this issue.

I'm inclined to use option b (simpler and safer, also considering we're in a 
freeze).
Comment 2 Kevin Kofler 2008-04-09 12:12:57 EDT
I guess there's an option c: read the default option out of the kiosky settings 
and copy it there with some sed magic in startkde.
Comment 3 Kevin Kofler 2008-04-09 13:59:24 EDT
Should be fixed in kdebase-workspace-4.0.3-11.fc9.
Comment 4 Kevin Kofler 2008-04-09 14:27:13 EDT
(FYI, option c is the one which has been implemented.)
Comment 5 Kevin Kofler 2008-04-12 01:51:40 EDT
Should be fixed.
If it's still not working, then please reopen it and we'll have to work on 
implementing option a.

Note You need to log in before you can comment on or make changes to this bug.