Bug 44159 - Installation is VERY VERY slow, too slow to complete this year
Installation is VERY VERY slow, too slow to complete this year
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-11 18:21 EDT by John McLaughlin
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-12 19:38:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John McLaughlin 2001-06-11 18:21:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
When booting from the RH7.1 CDROM, and running *any* install mode (normal, 
expert, lowres, nofb, text) it gets to the "/sbin/loader" execution fairly 
quickly, and then becomes "CPU starved".  

How reproducible:
Always

Steps to Reproduce:
When booting from the RH7.1 CDROM and proceeding with any install option, 
it literally takes 30-60 minutes to go from "blue screen" to "blue screen 
with 'running anaconda - please wait'" and 2-3 hours to get to the point 
where the GUI screen is displayed.  At that point the mouse is non-
responsive, and proceeding via keyboard control takes several minutes to 
change screens.


Additional info:

The system has everything possible removed and disabled.  Basic specs are: 
IWIL MOBO (Via CS), Intel 800MHz Celeron, 256MB RAM, 40GB HD, basic Matrox 
VGA.  Onboard USB is disabled.  The only add in card is PCI VGA.  Has one 
HD (IDE 0 Master), one CDROM (IDE 1 Master), and one FDD.
Comment 1 Brent Fox 2001-06-11 18:40:53 EDT
Does the kernel identify all your memory?  Can you look on VC2 and run 'cat
/proc/meminfo'?
Comment 2 John McLaughlin 2001-06-11 19:06:22 EDT
On VC2, 'cat /proc/meminfo' took over 1 minute to display output, and it 
appears to see all the system RAM.  Summary:

Total: 261,763,072
Used: 24,494,080
Free: 237,268,992
Buffers: 4,333,568
Cached: 14,729,216
Comment 3 Brent Fox 2001-06-12 10:30:37 EDT
Wow.  I've never seen anything like this.  The output of 'cat /proc/meminfo'
should be instantaneous.  This sounds like it could be a kernel problem...I
can't think of anything in the installer that would cause this to happen.  Can
you look on VC3 and VC4 and see if there are any error messages?  There could be
problems reading the cdrom.  If you listen to the machine, does it sound like
the cdrom drive is spinning down and then spinning up again repeatedly?
Comment 4 John McLaughlin 2001-06-12 14:05:22 EDT
I was seeing a number of errors on VC4 pertaining to the CDROM, though the CD 
was not spinning or starting/stopping repeatedly.  Most of the errors were hdX: 
Interrupt Lost.  I first saw hdc, when the CDROM was Secondary IDE Master, and 
then hdb after I tried switching to Primary Slave.  I confirmed master/slave 
jumper on drive, tried swapping actual CDROM drives, internal ribbon cables, 
primary to secondary controllers, etc.

At this point I suspect the motherboard.  Do you have an opinion?  I believe I 
will try a different MOBO.
Comment 5 Brent Fox 2001-06-12 14:41:13 EDT
It could be the motherboard...but I can't be sure.  It does sound like something
is not quite right with the hardware.
Comment 6 John McLaughlin 2001-06-12 19:38:46 EDT
I exchanged the IWILL VX133 w/800MHz Celeron for an IWILL 266 with a 900 MHz 
AMD Athlon and it ran normally the first time I tried to install RH7.1.  I also 
upgraded the Video to NVIDIA 32 MB AGP.

Sorry to bother you guys with what turned out to be a hardware issue (but it 
may be a Linux/VX133 compatibility issue).

Thanks for your help and time.

Note You need to log in before you can comment on or make changes to this bug.