Bug 441602 - weird echo behavior in bash
weird echo behavior in bash
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 18:11 EDT by Allan Kugel
Modified: 2014-01-12 19:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 09:40:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allan Kugel 2008-04-08 18:11:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008031714 Fedora/3.0-0.44.cvs20080315.fc9 Minefield/3.0b5pre

Description of problem:
as root, type echo /*/default.conf and bash just sits there until interrupted

Version-Release number of selected component (if applicable):
GNU bash, version 3.2.33(1)-release (i386-redhat-linux-gnu)

How reproducible:
Always


Steps to Reproduce:
1. type "echo /*/foo" 
2. nothing happens
3. type interupt (I need to do it twice) to 

Actual Results:
bash hangs until interrupted.

Expected Results:
bash should have echoed "/*/foo" and prompted for the next input line.


Additional info:
works without problem on SunOS, other linux machines (including Fedora Core 6)
Comment 1 Allan Kugel 2008-04-08 18:27:04 EDT
I have rebooted the system, and the problem has gone away.
Comment 2 Tomas Janousek 2008-04-09 04:51:47 EDT
Timed out NFS/samba/whatever mount of some directory in / ?
Comment 3 Bug Zapper 2008-05-14 05:09:42 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Roman Rakus 2008-05-28 11:57:28 EDT
Does problem persist? Or was it by something in Comment #2? Or whatever?
Comment 5 Roman Rakus 2008-11-13 09:40:54 EST
No response. And looks like not a bug. If you want to get echoed /*/foo you can use:
echo '/*/echo'
Closing notabug
Comment 6 Roman Rakus 2008-11-13 09:41:31 EST
typo:
echo '/*/foo'

Note You need to log in before you can comment on or make changes to this bug.