Bug 441616 - Kernel panic on 2.6.24.3-50.fc8 and 2.6.24.4-60.fc8 on VMWare machine.
Kernel panic on 2.6.24.3-50.fc8 and 2.6.24.4-60.fc8 on VMWare machine.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 22:23 EDT by RevRagnarok
Modified: 2009-01-09 01:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 01:21:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RevRagnarok 2008-04-08 22:23:25 EDT
Description of problem:
Kernel panic with kernels 2.6.24.3-50.fc8 and 2.6.24.4-60.fc8 on a VMWare
machine with SCSI virtual drives.

Version-Release number of selected component (if applicable):
2.6.24.3-50.fc8 BAD
2.6.24.4-60.fc8 BAD
2.6.24.3-34.fc8 GOOD

How reproducible:
Always

Steps to Reproduce:
1. Upgrade past 2.6.24.3-34
2. Reboot
  
Actual results:
Kernel panic about "No init found" and to try adding it to the command line.
This is right after it write-protects certain kernel data.

Expected results:
Machine boots.

Additional info:
It looks like the SCSI driver isn't showing up - the working kernel in verbose
mode tells me that it initialized the BT-958. It crashes right before that
should happen - the "good" boot says "Write protecting the kernel read-only
data" and then loads up the ohci_hcd driver followed by the SCSI subsystem
initialization.
Comment 1 Chuck Ebbert 2008-04-16 19:17:43 EDT
Is the initrd's init script loading the BT driver?

See http://fedoraproject.org/wiki/KernelCommonProblems for how to examine the
initrd contents.
Comment 2 RevRagnarok 2008-04-16 20:20:01 EDT
I cannot tell offhand, but I am seeing a big problem!

I checked the initrd files for:
initrd-2.6.24.3-34.fc8.img
initrd-2.6.24.3-50.fc8.img
initrd-2.6.24.4-64.fc8.img

It looks like after 34, the "init" file has been corrupted!? They both have a
bunch of nulls at the beginning instead of "#!/bin/nash" and all the other setups.

rpm -qa | grep kernel | xargs rpm -V says nothing
rpm -qa | grep kernel | xargs rpm -v -V | grep initrd also has nothing

Very odd. Any ideas???


Comment 3 Chuck Ebbert 2008-04-18 14:53:38 EDT
You could try booting the working kernel and rebuilding the initrds for the
newer ones. (but make backups first)
Comment 4 RevRagnarok 2008-04-20 08:40:31 EDT
I tried that, no luck. If I try to use the older initrd on the newer kernel, the
keys don't match so it won't load kernel modules. I tried to re-build the initrd
by copying the /etc/init script from the working copy. I got the same error
about it not finding init (and again, it didn't load the BusLogic modules). 

However, this doesn't explain the NULLs at the beginning of the "init" in two
initrd files that rpm thinks is fine.


Comment 5 Chuck Ebbert 2008-04-23 00:15:24 EDT
(In reply to comment #4)
> I tried that, no luck. If I try to use the older initrd on the newer kernel, the
> keys don't match so it won't load kernel modules.

You need to tell mkinitrd which kernel you are building the initrd for.

Comment 6 RevRagnarok 2008-04-23 00:49:29 EDT
I was able to get mkinitrd to work. However, I would like to understand why (a)
rpm didn't complain about the file, (b) why when I rebuilt it by hand it didn't
work, and (c) what happened to make me need to run it manually for every new
kernel...
Comment 7 Chuck Ebbert 2008-04-23 21:25:05 EDT
rpm can't verify the initrd file because it gets custom-built for each installation.

Comment 8 RevRagnarok 2008-05-12 10:22:11 EDT
Newest update (2.6.24.5-85.fc8) still fails. Again, a manual "mkinitrd" run
solved the issue, but to do that I need a previous kernel that runs and is still
installed.
Comment 9 RevRagnarok 2008-08-03 09:17:49 EDT
I think I have found the issue. It was with Zerotools (1) which zeros out files when they are unlinked, a very useful feature when working with virtual machines. On a whim yesterday, I reverted back to the previous kernel and then erased the RPMs for the newest. I removed the Zerotools yum wrapper and did "yum upgrade". The new kernel booted fine. 

It looks like either yum or mkinitrd is doing something odd with the disk I/O, possibly unlinking the file and then assuming it is still valid (2). If that's the case, this could be a problem on other file systems where you cannot assume data is retained after unlink. However, I looked through the mkinitrd script and the last 15-20 lines seem to be where that action is and it looks fine by me. So I'm leaving it up to the powers-that-be to decide if this really is a mkinitrd bug or not.

(1) http://www.koltsoff.com/pub/zerotools/
(2) http://www.koltsoff.com/pub/zerotools/#toc17 "Problem Cases"
Comment 10 Bug Zapper 2008-11-26 05:26:54 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2009-01-09 01:21:23 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.