Bug 441630 - client kernel panic on RHEL5.1 host
Summary: client kernel panic on RHEL5.1 host
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-xen-2.6   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Xen Maintainance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-09 06:48 UTC by Jeff Fearn 🐞
Modified: 2009-02-25 11:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 11:42:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xm create -c output (5.07 KB, text/plain)
2008-04-09 06:48 UTC, Jeff Fearn 🐞
no flags Details

Description Jeff Fearn 🐞 2008-04-09 06:48:05 UTC
Description of problem:
Booting a 32bit rawhide client on a RHEL5.1 64bit host causes a kernel panic.

Version-Release number of selected component (if applicable):
2.6.25-0.18.rc8.fc9.i686.xen

How reproducible:
Always

Steps to Reproduce:
1. get a 32bit RawHide image
2. run it on a RHEL 5.1 64bit host

  
Actual results:
Kernel panic - not syncing: Attempted to kill the idle task!

Expected results:
Client boots

Additional info:
Host is RHEL 5.1, fully up to date.
Client is rawhide, fully up to date.

This was working earlier in the year but I haven't started it for a while. When
I did start it I ran yum update and rebooted. Since then I have had this error.

I can still boot on the old kernel: 2.6.21.7-2892.fc9.i686.xen

Comment 1 Jeff Fearn 🐞 2008-04-09 06:48:05 UTC
Created attachment 301754 [details]
xm create -c output

Comment 2 Jeff Fearn 🐞 2008-04-18 05:11:09 UTC
This is still happening with the latest RawHid xen kernel.

[root@obelisk ~]# xm create -c RawHide2

Using config file "/etc/xen/RawHide2".

Started domain RawHide2

------------[ cut here ]------------

kernel BUG at arch/x86/xen/time.c:122!

invalid opcode: 0000 [#1] SMP 

Modules linked in:



Pid: 0, comm: swapper Not tainted (2.6.25-0.24.rc9.fc9.i686.xen #1)

EIP: e019:[<c0405bf3>] EFLAGS: 00010282 CPU: 0

EIP is at xen_setup_timer+0xa2/0xae

EAX: fffffff2 EBX: 00000005 ECX: 00000000 EDX: c0756f80

ESI: c063e548 EDI: 00000005 EBP: c0756f94 ESP: c0756f7c

 DS: e021 ES: e021 FS: 00d8 GS: 0000 SS: e021

Process swapper (pid: 0, ti=c0756000 task=c071f3a0 task.ti=c0756000)

Stack: c1898c18 c1898bac 6577d561 00000007 00000000 00000000 c0756fa8 c076373b 

       00000020 c07a6968 c189f968 c0756fd4 c075d8a1 3f861000 00001e5a c18a2000 

       0000a000 00007968 c078680c 00864000 c07867e4 c0722b80 c0756ffc c07632ea 

Call Trace:

 [<c076373b>] ? xen_time_init+0xd7/0xe4

 [<c075d8a1>] ? start_kernel+0x2b7/0x345

 [<c07632ea>] ? xen_start_kernel+0x32c/0x334

 =======================

Code: 00 00 00 89 51 20 8d 55 ec 89 41 1c b8 ac fb 79 c0 89 d9 03 04 9d 80 30 75
c0 89 fb 89 45 ec e8 14 47 3a 00 83 c4 0c 85 c0 74 04 <0f> 0b eb fe 8d 65 f4 5b
5e 5f 5d c3 55 b8 18 fc 79 c0 89 e5 57 

EIP: [<c0405bf3>] xen_setup_timer+0xa2/0xae SS:ESP e021:c0756f7c

---[ end trace ca143223eefdc828 ]---

Kernel panic - not syncing: Attempted to kill the idle task!



Comment 3 Jeff Fearn 🐞 2008-04-22 05:46:17 UTC
Updated Kernel is still behaving badly :(

Using config file "/etc/xen/RawHide".

Started domain RawHide

------------[ cut here ]------------

kernel BUG at arch/x86/xen/time.c:122!

invalid opcode: 0000 [#1] SMP 

Modules linked in:



Pid: 0, comm: swapper Not tainted (2.6.25-1.fc9.i686.xen #1)

EIP: e019:[<c0405bf3>] EFLAGS: 00010282 CPU: 0

EIP is at xen_setup_timer+0xa2/0xae

EAX: fffffff2 EBX: 00000005 ECX: 00000000 EDX: c0756f80

ESI: c063e540 EDI: 00000005 EBP: c0756f94 ESP: c0756f7c

 DS: e021 ES: e021 FS: 00d8 GS: 0000 SS: e021

Process swapper (pid: 0, ti=c0756000 task=c071f3a0 task.ti=c0756000)

Stack: c1876c18 c1876bac e7e08c23 00000007 00000000 00000000 c0756fa8 c076373b 

       00000020 c07a6968 c187d968 c0756fd4 c075d8a1 3f861000 00001e5a c1880000 

       0000a000 00007968 c078680c 00864000 c07867e4 c0722b80 c0756ffc c07632ea 

Call Trace:

 [<c076373b>] ? xen_time_init+0xd7/0xe4

 [<c075d8a1>] ? start_kernel+0x2b7/0x345

 [<c07632ea>] ? xen_start_kernel+0x32c/0x334

 =======================

Code: 00 00 00 89 51 20 8d 55 ec 89 41 1c b8 ac fb 79 c0 89 d9 03 04 9d 80 30 75
c0 89 fb 89 45 ec e8 14 47 3a 00 83 c4 0c 85 c0 74 04 <0f> 0b eb fe 8d 65 f4 5b
5e 5f 5d c3 55 b8 18 fc 79 c0 89 e5 57 

EIP: [<c0405bf3>] xen_setup_timer+0xa2/0xae SS:ESP e021:c0756f7c

---[ end trace ca143223eefdc828 ]---

Kernel panic - not syncing: Attempted to kill the idle task!



Comment 4 Bug Zapper 2008-05-14 09:10:20 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Chris Lalancette 2009-01-22 10:31:11 UTC
There are a couple of things going on here: it's possible that this was either a bug in the F-9 i386 xen kernel, or a bug in the RHEL 5.1 32-bit PV on 64-bit host support.  In any case, I've now been able to successfully boot a 32-bit F-9 guest on both a 5.2 and 5.3 64-bit Xen system.  Can you try this again and see if it now works?

Thanks,
Chris Lalancette

Comment 6 Jeff Fearn 🐞 2009-02-25 06:21:44 UTC
Hi, this works for me now, thanks :)

Comment 7 Mark McLoughlin 2009-02-25 11:42:53 UTC
Thanks


Note You need to log in before you can comment on or make changes to this bug.