Bug 441647 - XV crashes with BadAlloc when compositing manager is enabled
XV crashes with BadAlloc when compositing manager is enabled
Status: CLOSED DUPLICATE of bug 239125
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 06:25 EDT by Mohd Izhar Firdaus Ismail
Modified: 2008-04-09 07:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 07:49:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.0.log (23.92 KB, application/octet-stream)
2008-04-09 06:25 EDT, Mohd Izhar Firdaus Ismail
no flags Details

  None (edit)
Description Mohd Izhar Firdaus Ismail 2008-04-09 06:25:26 EDT
Description of problem:
XV crashed with BadAlloc

Totem: 
The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 71 error_code 11 request_code 140 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Mplayer:
Starting playback...
VDec: vo config request - 704 x 396 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 704x396 => 704x396 Planar YV12 
[ws] Error in display.  0.171 ct:  0.000   1/  1 ??% ??% ??,?% 0 0 1%           
[ws]  Error code: 11 ( BadAlloc (insufficient resources for operation) )
[ws]  Request code: 140
[ws]  Minor code: 19
[ws]  Modules: flip_page



Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.2.1-19.fc9.i386

How reproducible:
Everytime

Steps to Reproduce:
1.Enable compositing manager ( either compiz or metacity's compositing )
2.Play a video using XV output
  
Actual results:
XV crashed with BadAlloc

Expected results:
Video plays

Additional info:
Video plays correctly if compositing disabled.

attached together Xorg.0.log
Comment 1 Mohd Izhar Firdaus Ismail 2008-04-09 06:25:26 EDT
Created attachment 301774 [details]
xorg.0.log
Comment 2 Matěj Cepl 2008-04-09 07:49:58 EDT

*** This bug has been marked as a duplicate of 239125 ***

Note You need to log in before you can comment on or make changes to this bug.