Bug 441653 - vcpu can not be set to more than 1
vcpu can not be set to more than 1
Status: CLOSED DUPLICATE of bug 434570
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
: 456343 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 07:14 EDT by Ilkka Tengvall
Modified: 2008-09-16 11:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 11:42:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ilkka Tengvall 2008-04-09 07:14:39 EDT
Description of problem:

Both virt-manager and virt-install decline of setting virtual cpu count to any
higher than 1. Using qemu-kvm I get to set it to higher. I'm currently
installing rhel5 for 2 virtualcpu virtual machine via qemu-kvm.

The real CPU is 4 core intel 5420, which should work.

I'm running Fedora 9 beta with rawhide updates.

Version-Release number of selected component (if applicable):
kvm-64-3.fc9.x86_64
fedora-release-8.92-1.noarch
virt-manager-0.5.4-3.fc9.x86_64
python-virtinst-0.300.3-4.fc9.noarch
Linux whipper 2.6.25-0.204.rc8.git4.fc9.x86_64 #1 SMP Mon Apr 7 10:25:52 EDT
2008 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

every time the same failure.

Steps to Reproduce:
1.

Open the virtual machine manager and start creating a new machine. Try setting
vcpu count to higher than 1.

or

$ sudo virt-install -n virt-install-fail -r 1024 --vcpus=2 -f
/tmp/virt-install.img -s 2000 -v --vnc  -c /home/itengval/Desktop/boot-i386.iso
--os-type=linux --os-variant=rhel5  --connect qemu:///system --accelerate 

2.
3.
  
Actual results:
output:
"ERROR:  Number of vcpus must be in the range of 1-1"



Expected results:
Just use 2 cpu's as instructed. By using qemu-kvm directly it works. 

Additional info:
Comment 1 Bug Zapper 2008-05-14 05:11:00 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Daniel Berrange 2008-05-19 12:53:27 EDT
This is libvirt reporting the wrong info for the KVM cpu limit.
Comment 3 Cole Robinson 2008-09-03 16:31:54 EDT
*** Bug 456343 has been marked as a duplicate of this bug. ***
Comment 4 Cole Robinson 2008-09-16 11:42:02 EDT

*** This bug has been marked as a duplicate of bug 434570 ***

Note You need to log in before you can comment on or make changes to this bug.