Bug 441665 - [830M] Slight display corruption with some graphics
[830M] Slight display corruption with some graphics
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 08:12 EDT by Ralf Ertzinger
Modified: 2010-04-26 17:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 17:40:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of normal icon bar (9.42 KB, image/png)
2008-04-09 08:13 EDT, Ralf Ertzinger
no flags Details
Corrupted icon bar (7.85 KB, image/png)
2008-04-09 08:13 EDT, Ralf Ertzinger
no flags Details
Xorg.0.log with -17 (21.96 KB, text/plain)
2008-04-09 08:16 EDT, Ralf Ertzinger
no flags Details
Xorg.0.log with -20 (21.15 KB, text/plain)
2008-04-09 08:16 EDT, Ralf Ertzinger
no flags Details
xorg.conf for both cases (2.14 KB, text/plain)
2008-04-09 08:17 EDT, Ralf Ertzinger
no flags Details

  None (edit)
Description Ralf Ertzinger 2008-04-09 08:12:27 EDT
Description of problem:
Versions after xorg-x11-drv-i810-2.2.1-17.fc9.i386 show slight display
corruption with some programs (not all). Please see the screenshots below.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.2.1-20.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Install version later than xorg-x11-drv-i810-2.2.1-17.fc9.i386
2. Start claws-mail
3.
  
Actual results:
Corrupted icons

Expected results:
Normal icons

Additional info:
Comment 1 Ralf Ertzinger 2008-04-09 08:13:32 EDT
Created attachment 301787 [details]
Screenshot of normal icon bar
Comment 2 Ralf Ertzinger 2008-04-09 08:13:53 EDT
Created attachment 301788 [details]
Corrupted icon bar
Comment 3 Ralf Ertzinger 2008-04-09 08:16:14 EDT
Created attachment 301789 [details]
Xorg.0.log with -17
Comment 4 Ralf Ertzinger 2008-04-09 08:16:34 EDT
Created attachment 301791 [details]
Xorg.0.log with -20
Comment 5 Ralf Ertzinger 2008-04-09 08:17:04 EDT
Created attachment 301792 [details]
xorg.conf for both cases
Comment 7 Bill Nottingham 2008-04-09 16:59:10 EDT
-17 is using XAA, -20 is using EXA (from the logs)
Comment 8 Ralf Ertzinger 2008-04-10 14:36:45 EDT
Setting -20 to XAA crashes X, hard.

Disabling intel-batchbuffer, however, makes the corrupt icons disappear.
Comment 9 Callum Lerwick 2008-04-29 01:43:54 EDT
I think I'm seeing a similar/same bug. xorg-x11-drv-i810-2.2.1-22.fc9.i386, on
an Intel 830M laptop with "intel" driver. But mostly with text, rather than
icons. Screenshot here:

http://www.flickr.com/photos/ninjaseg/2447596526/

It starts out slight, but it gets worse over time. That screenshot is after
letting it get particularly bad. I wasn't able to get a good shot of non-font
corruption but you can see some in my gkrellm, in the upper left corner of the
main evolution menu, and my pidgin icon in the upper right. Definately seems
like the pixmap cache is getting stomped on somehow. Flipping to a text console
and back to X fixes it temporarily, but it just gets corrupted again after a few
minutes.

I noticed the logs said it was using EXA, but I'm not sure what it was using
before. But I switched it to XAA and it seems to work fine now, on my hardware.

Should I open my own bug or use this one?
Comment 10 Bug Zapper 2008-05-14 05:11:51 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Jón Fairbairn 2008-06-05 04:01:54 EDT
I'm getting the same as comment#9; I wouldn't call this slight corruption!

IBM X30 laptop,  Intel Corporation 82830 CGC, intel_drv.so from
xorg-x11-drv-i810-2.2.1-24.fc9.i386



It looks like using 
         Option "AccelMethod" "XAA"
in xorg.conf is a work around for now.
Comment 12 Callum Lerwick 2008-08-01 12:42:08 EDT
Sigh, I just tried removing the workaround. This bug still exists with
xorg-x11-drv-i810-2.3.2-2.fc9.i386

Back to XAA I guess.
Comment 13 Callum Lerwick 2008-11-24 23:05:41 EST
EXA on 830M is still broken in Fedora 10, as of xorg-x11-drv-i810-2.5.0-3.fc10.i386

In fact it got worse, the X server locks the entire system up hard as soon as any bitmaps are drawn. Reverting to XAA works. So... should 830M default to XAA perhaps? So that we can have working LiveCDs?
Comment 14 Dan Williams 2009-01-08 11:22:00 EST
Also try:

Option "EXANoComposite" "true"

in a minimal xorg.conf.  I'm trying to track this down.  The core issue is something in the acceleration code is causing the chipset to lock up.  Need to track down what that commit was, the most likely place is i830_render.c in the driver sources.

If people could try EXANoComposite=true and report if that works or not, that would be great.
Comment 15 Callum Lerwick 2009-01-08 20:33:21 EST
On my system, "EXANoComposite" "true" seems to work. Xorg log indicates EXA is in use:

(**) intel(0): Option "EXANoComposite" "true"
(**) intel(0): EXA: Disabling Composite operation (RENDER acceleration)
(II) EXA(0): Offscreen pixmap area of 12582912 bytes
(II) EXA(0): Driver registered support for the following operations:
(II)         Solid
(II)         Copy
Comment 16 Bug Zapper 2009-06-09 20:05:47 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Bug Zapper 2009-07-14 13:35:54 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 18 Callum Lerwick 2009-07-24 21:27:31 EDT
Hmmm, I tried removing xorg.conf and this appears fixed in Fedora 11 as of at least:

xorg-x11-drv-intel-2.7.0-7.fc11.i586

Leaving closed.
Comment 19 Callum Lerwick 2009-07-31 03:28:59 EDT
Spoke too soon. After running for a while I'm still seeing the same corruption, though it's much rarer now.

Re-opening.
Comment 20 Vedran Miletić 2009-09-06 04:39:16 EDT
Adjusting version per comment #18.
Comment 21 Matěj Cepl 2009-11-05 13:19:10 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 22 Matěj Cepl 2010-02-26 07:18:48 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 23 Adam Jackson 2010-04-26 17:40:13 EDT
Closing per comment #22.

Note You need to log in before you can comment on or make changes to this bug.