Bug 441715 - Miro can no longer play the channels
Miro can no longer play the channels
Status: CLOSED DUPLICATE of bug 441705
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Thorsten Scherf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 12:51 EDT by Peter Janakiev
Modified: 2008-04-12 04:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-12 04:51:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Janakiev 2008-04-09 12:51:24 EDT
Description of problem:
With todays (09 04 2008) update of Miro (plus xine libs) Miro can no longer play
the channels subscribed ( it gives "Miro cannot play this file, try with
external application or skip). It can play AVI files and Flash files but it
display very strange colors now (like I have bumped the saturation using the Xv
overlay) 


Version-Release number of selected component (if applicable):
Miro-1.2-1.fc8

How reproducible:
Always

Steps to Reproduce:
1.Start Miro
2.Select one of the channels with saved videos from before 
3.try to play the video
  
Actual results:
Miro is unable to play it

Expected results:
Miro should play the episode as usual.


Additional info:
Updated xine libs:
Apr 09 19:00:09 Updated: xine-lib - 1.1.11.1-1.fc8.i386
Apr 09 19:03:21 Updated: xine-lib-extras-nonfree - 1.1.11.1-1.lvn8.i386
Apr 09 19:03:44 Updated: xine-lib-extras - 1.1.11.1-1.fc8.i386
I am not sure is this is related but as far as I know miro uses xine on linux to
play the video. It gives no error on the miro log to signify that the video
cannot be played: 
INFO     got action:playViewNamed?viewName=watchableItems&firstItemId=5010
INFO     got file:///tmp/tmpyD7S6d.html
INFO     Up to date.
INFO     got javascript:skipItem(5010)
INFO     got action:skipItem?itemID=5010
INFO     got file:///tmp/tmph8BzTw.html

please plese please help, i watch my channels every day and it is impossible now...
Comment 1 Alex Lancaster 2008-04-09 20:32:56 EDT
I can't reproduce this on F-8 with the latest updates applied with the videos
I've downloaded.  Can you post the exact URL to the channel and/or the file.  It
would be useful to know the file type of the file you're trying to play too.

Sounds like xine-lib problem.  Do you have the xine-lib-extras-nonfree package
from livna too?  Can you try switching to the gstreamer backend? 
Video->Options->Playback "use this renderer to play videos": gstreamer.

You'll need to make sure that you have gstreamer-ffmpeg and
gstreamer-plugins-{ugly,bad} from livna also installed.  I notice that the
plugins won't play .avi or mp4 files, but play most other types.
Comment 2 Peter Janakiev 2008-04-10 02:46:04 EDT
Okay, I have made some tests:
Updated only Miro on a spare laptop to Miro-1.2-1.fc8 without updating Xine libs.

Results:
Videos are played fine but the reaction to user input is much much slower in the
new version it takes like 20 seconds to react on pause button press for example
or to Ctrl + F for full screen. 

I have tried and switched to Gstreamer
Result: While in gstreamer properties I have enabled Xv overlay playback and it
is working for Totem, Miro is always starting with X11 backend which render the
playback unusable for any movie, let alone HD movies. Can this be forced to
check for Xv extension on the Xserver? And how is it working for totem (with
gstreamer backend) and not for Miro? I believe it is something to do with Miro
itslef.

As of Xine update - i will make additional test by updating (with rollback, just
to be safe) to the latst available. If it proves to be in Xine i should submit a
new bug to xine-libs?
Comment 3 Peter Janakiev 2008-04-10 02:54:57 EDT
Expeccted results confirmed - it is caused by xine libs 
File :
step_brothers-tlr1r_h640w.mov
cannot be played 
Playback control is not working (the timeline slider is not responding to
scrolling - you cannot forward ot rewind in the playback). 
The strange colors are not related, maybe i messed up on the other laptop, so it
is just the playback and the file type support. 

As xine libs nonfree is not part of fedora, where should I submit this bug?
Thanks
Comment 4 Rex Dieter 2008-04-10 13:40:07 EDT
This is likely related to bug #441705 (xine-lib), and has an update pending.
Comment 5 Alex Lancaster 2008-04-12 04:51:09 EDT
(In reply to comment #3)
> Expeccted results confirmed - it is caused by xine libs 
> File :
> step_brothers-tlr1r_h640w.mov
> cannot be played 
> Playback control is not working (the timeline slider is not responding to
> scrolling - you cannot forward ot rewind in the playback). 
> The strange colors are not related, maybe i messed up on the other laptop, so it
> is just the playback and the file type support. 

Yes, the update:

https://admin.fedoraproject.org/updates/F8/pending/xine-lib-1.1.11.1-1.fc8.1

fixes this.  If you want to check that it fixes it for you and don't want to
wait until it it pushed to the repos, you can manually download the RPMS from here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=45756

> As xine libs nonfree is not part of fedora, where should I submit this bug?
> Thanks

Closing as a duplicate as per comment #4.

*** This bug has been marked as a duplicate of 441705 ***

Note You need to log in before you can comment on or make changes to this bug.