Bug 441725 - git - perl-Git shouldn't provide perl(Error)
git - perl-Git shouldn't provide perl(Error)
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: git (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 13:37 EDT by Jose Pedro Oliveira
Modified: 2013-01-10 05:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 18:26:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2008-04-09 13:37:34 EDT
Description of problem:
The is a packing error in Git as it perl-Git subpackage erroneously provides
perl(Error).  This perl module should be provided by the perl-Error package
(which appears to be missing in EPEL).


Version-Release number of selected component (if applicable):
git-1.5.3.6-1

How reproducible:
Always.
It adds to its requirements perl-Git and git-core.


Steps to Reproduce:
In a clean machine:
1. yum install rt3
2. look at the requirements list: it includes perl-Git and git-core.
  
Actual results:
perl-Git and git-core are installed.

Expected results:
No git packages installed. 

Additional info:
The rawhide git package in rawhide appears to be ok as perl-Git no longer
provides perl(Error).


EPEL
----
$ rpm -q --provides perl-Git
perl(Error) = 0.15009
perl(Error::Simple)  
perl(Error::subs)  
perl(Git) = 0.01
perl(Git::Error::Command)  
perl(Git::activestate_pipe)  
perl-Git = 1.5.3.6-1.el5

Rawhide
$ rpm -qp --provides perl-Git-1.5.4.5-3.fc9.i386.rpm 
perl(Git) = 0.01
perl(Git::Error::Command)  
perl(Git::activestate_pipe)  
perl-Git = 1.5.4.5-3.fc9

/jpo
Comment 1 Jose Pedro Oliveira 2008-04-09 13:41:37 EDT
Adding the RT3 EPEL maintainer to the CC: list.

* there is no rt3 component in Fedora EPEL in Bugzilla
* the perl-Error package needs to be added to EPEL5 

/jpo
Comment 2 Xavier Bachelot 2008-04-09 15:22:33 EDT
 
> * there is no rt3 component in Fedora EPEL in Bugzilla
I've asked in #fedora-admin, they'll look at it

> * the perl-Error package needs to be added to EPEL5 
> 
filed as bz#441733


Comment 3 Xavier Bachelot 2008-06-02 10:27:51 EDT
Is anyone taking care of the git bug ? Trying to install rt3 on EL-5 results in
git-core and perl-Git dependencies. The bug is open for almost 2 months now
without a single comment from the maintainer, this doesn't fit well with EPEL.
Comment 4 Josh Boyer 2008-06-02 10:55:53 EDT
(In reply to comment #3)
> Is anyone taking care of the git bug ? Trying to install rt3 on EL-5 results in
> git-core and perl-Git dependencies. The bug is open for almost 2 months now
> without a single comment from the maintainer, this doesn't fit well with EPEL.

Do you have a patch that fixes this issue?
Comment 5 Jose Pedro Oliveira 2008-06-02 11:08:57 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > Is anyone taking care of the git bug ? Trying to install rt3 on EL-5 results in
> > git-core and perl-Git dependencies. The bug is open for almost 2 months now
> > without a single comment from the maintainer, this doesn't fit well with EPEL.
> 
> Do you have a patch that fixes this issue?

Please read the opening comment (Additional info section).


Comment 6 Xavier Bachelot 2008-06-02 11:17:54 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > Is anyone taking care of the git bug ? Trying to install rt3 on EL-5 results in
> > git-core and perl-Git dependencies. The bug is open for almost 2 months now
> > without a single comment from the maintainer, this doesn't fit well with EPEL.
> 
> Do you have a patch that fixes this issue?

No, I don't but I could if the maintainer said he doesn't have time to work on
the issue. The missing perl-Error package issue was taken care of within days
because the maintainer was responsive and allowed me to take care of it by
myself. Just to be clear, I'm not moaning because the issue was not magically
fixed, but because the maintainer didn't comment on the bug.
Comment 7 Josh Boyer 2008-06-02 14:39:04 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > Is anyone taking care of the git bug ? Trying to install rt3 on EL-5
results in
> > > git-core and perl-Git dependencies. The bug is open for almost 2 months now
> > > without a single comment from the maintainer, this doesn't fit well with EPEL.
> > 
> > Do you have a patch that fixes this issue?
> 
> Please read the opening comment (Additional info section).

Ok, so I'm confused.  The spec file in EL-5 looks fairly identical to what is in
rawhide.

What exactly is the problem?
Comment 8 Xavier Bachelot 2008-06-02 17:50:22 EDT
The EL-5 perl-Git subpackage (git-1.5.3.6) provides perl(Error), while the
Rawhide subpackage (1.5.5.3) correctly does not. 

git ships with a private copy of Error.pm : git-1.5.?.?/perl/private-Error.pm
and git-1.5.?.?/perl/Makefile.PL contains the following :

# We come with our own bundled Error.pm. It's not in the set of default
# Perl modules so install it if it's not available on the system yet.
eval { require Error };
if ($@ || $Error::VERSION < 0.15009) {
        $pm{'private-Error.pm'} = '$(INST_LIBDIR)/Error.pm';
}

Adding a BuildRequires: perl(Error) fixes the EL-5 issue.
It probably make sense to remove this private copy and BuildRequires:
perl(Error) instead in all the branches.
Comment 9 Josh Boyer 2008-06-02 18:03:49 EDT
This is the EL-5 spec file in CVS:

%package -n perl-Git
Summary:        Perl interface to Git
Group:          Development/Libraries
Requires:       git = %{version}-%{release}, perl(Error)
Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)


This is the rawhide spec file in CVS:

%package -n perl-Git
Summary:        Perl interface to Git
Group:          Development/Libraries
Requires:       git = %{version}-%{release}, perl(Error)
Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)

They are identical.  So, this is already fixed, yes?
Comment 10 Xavier Bachelot 2008-06-02 18:16:44 EDT
Yes, it is fixed in the current EL5 testing package (1.5.5.1-2.el5). I didn't
look at the spec in CVS but at the spec of the latest stable package
(1.5.3.6-1.el5). 
Comment 11 Josh Boyer 2008-06-02 18:26:32 EDT
Great.
Comment 12 Xavier Bachelot 2008-06-03 05:28:29 EDT
Thanks for taking care of the bug Josh.
Comment 13 Xavier Bachelot 2008-06-29 16:45:16 EDT
the git packages cannot be move to EPEL stable because of RHBZ#453333
Comment 14 Xavier Bachelot 2008-07-07 16:43:59 EDT
I mis-read the EPEL broken deps report, the deps are broken only for EL-4, so
RHBZ#453333 is actually not impacting rt3.


Note You need to log in before you can comment on or make changes to this bug.