Bug 441729 - anaconda installs xenU kernel on real hardware
anaconda installs xenU kernel on real hardware
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.7
i386 Linux
high Severity high
: beta
: ---
Assigned To: Martin Sivák
Robert M Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 14:13 EDT by Bill Peck
Modified: 2008-07-24 15:06 EDT (History)
7 users (show)

See Also:
Fixed In Version: RHBA-2008-0653
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:06:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2008-04-09 14:13:15 EDT
Description of problem:
anaconda installs the xenU kernel

Version-Release number of selected component (if applicable):
RHEL4-U7-re20080409.nightly

How reproducible:
Everytime

Steps to Reproduce:
1. install RHEL4-U7-re20080409.nightly on i386
2.
3.
  
Actual results:
The highlighted entry will be booted automatically in 1 seconds.    
[H[J  Booting 'Red Hat Enterprise Linux AS (2.6.9-68.32.ELxenU)'

root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.9-68.32.ELxenU ro root=/dev/VolGroup00/LogVol00 console=tty
S0,115200n8

Error 13: Invalid or unsupported executable format

Press any key to continue...

Expected results:
not the xenU kernel should be loaded. :-)

Additional info:
RHEL4-U7-re20080407.nightly did install.  Jeff Burke did a diff between the
trees and anaconda didn't change.  So I'm a little confused.

broken install 0409.nightly
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=19770&type=Single
working install 0407.nightly
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=19594

http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=2599495
http://rhts.redhat.com/testlogs/19770/69106/583749/ks.cfg
http://rhts.redhat.com/testlogs/19770/69106/583749/anaconda.log
Comment 4 Chris Lumens 2008-04-11 05:34:55 EDT
The only reason this should ever happen is if /proc/xen exists on the system
being installed to.  Does this file now exist on the test systems?  If so, that
would indicate to me that something has changed in the kernel.
Comment 5 Martin Sivák 2008-04-11 06:58:09 EDT
I look like the kernel has been modified and provides /proc/xen directory even
in non-Xen environment. At least /proc/xen is present during vmware instalation.

So we have to figure out another way of detecting active Xen environment (or
revert the kernel change...).
Comment 7 Bill Peck 2008-04-15 08:57:02 EDT
Putting this back in assigned since Martin has answered the needinfo for me.
Comment 8 Martin Sivák 2008-04-15 10:42:45 EDT
I looked into machines running para-virt in Xen and into other (mostly vmware)
and it seems we can use the /proc/xen/capabilities file. So I updated the
algorithm and it should appear in 10.1.1.84.
Comment 9 David Lehman 2008-04-15 15:43:38 EDT
Fix is in anaconda-10.1.1.85-1.
Comment 13 errata-xmlrpc 2008-07-24 15:06:12 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0653.html

Note You need to log in before you can comment on or make changes to this bug.