Bug 441731 - monodevelop includes prebuilt and system libraries
monodevelop includes prebuilt and system libraries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: monodevelop (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 14:17 EDT by Toshio Ernie Kuratomi
Modified: 2008-05-11 16:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-11 16:58:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2008-04-09 14:17:06 EDT
Description of problem:
Some libraries includedin monodevelop are duplicates of libraries provided by
other packages and/or libraries with separate upstreams.  monodevelop cannot
ship these libraries as part of its package.

Version-Release number of selected component (if applicable):
monodevelop-0:0.19-2.fc9.i386

Steps to Reproduce:
One example:
1. repoquery --whatprovides --repoid=development 'mono(Mono.Cecil)'
  
Actual results:
mono-core-0:1.2.5.1-3.fc8.i386
monodevelop-0:0.19-2.fc9.i386
mono-core-0:1.9-3.fc9.i386
db4o-0:6.1-2.fc7.i386


Expected results:
mono-core-0:1.9-3.fc9.i386

Additional info:
monodevelop needs to be audited for libraries that it provides that have a
separate upstream and should be provided by those packages instead.
Comment 1 Toshio Ernie Kuratomi 2008-04-09 20:52:34 EDT
This package also has prebuilt binaries of nunit.core.dll  nunit.framework.dll
and does not appear to have source for them.
Comment 2 Toshio Ernie Kuratomi 2008-04-09 21:02:36 EDT
Correction.  There may be source for these in a higher level directory.  I
haven't checked the build process to see if they're rebuilt.
Comment 3 Paul F. Johnson 2008-04-22 10:12:56 EDT
There seems to be a problem with the nunit22.pc file in that it points to
/usr/lib instead of ${libdir}. If the build process doesn't find what it looks
for, it packages it's own copy.

I've emailed spot a fix for the .pc file.
Comment 4 Paul F. Johnson 2008-04-22 10:28:59 EDT
There is also the same sort of problem with mono-cecil-flowanalysis.pc...

Note You need to log in before you can comment on or make changes to this bug.