Bug 441737 - [fence] fence_node broken in RHEL5.2
[fence] fence_node broken in RHEL5.2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.2
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Lon Hohberger
GFS Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 14:31 EDT by Lon Hohberger
Modified: 2009-04-16 18:18 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0347
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:59:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patchy goodness. Tested against fence_node from 2.0.83-2 package (1.26 KB, patch)
2008-04-09 14:31 EDT, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2008-04-09 14:31:43 EDT
Description of problem: 

fence_node <name> and fence_node -O <name> always fail (and usually segfault)

This is because the API in agent.c and the API in fence_node.c don't match, but
because there's a correct prototype in fence_node.c, the compiler did not catch it.

agent.c: 
  int dispatch_fence_agent(char *victim, int force);

fence_node.c:
  int dispatch_fence_agent(int cd, char *victim);

Version-Release number of selected component (if applicable): cman-2.0.83-2

How reproducible: 100%
Comment 1 Lon Hohberger 2008-04-09 14:31:43 EDT
Created attachment 301872 [details]
Patchy goodness.  Tested against fence_node from 2.0.83-2 package
Comment 3 Kiersten (Kerri) Anderson 2008-04-09 16:02:23 EDT
Escalating for inclusion in RHEL 5.2.
Comment 8 errata-xmlrpc 2008-05-21 11:59:03 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0347.html

Note You need to log in before you can comment on or make changes to this bug.