Bug 441742 - dual-head monitor resolution problems
dual-head monitor resolution problems
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 14:45 EDT by Thomas J. Baker
Modified: 2010-03-18 13:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:28:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf (1.00 KB, text/plain)
2008-04-09 14:47 EDT, Thomas J. Baker
no flags Details
Xorg.0.log (66.49 KB, text/plain)
2008-04-09 14:47 EDT, Thomas J. Baker
no flags Details
/var/log/Xorg.0.log.old (44.37 KB, text/plain)
2008-05-07 15:44 EDT, Thomas J. Baker
no flags Details

  None (edit)
Description Thomas J. Baker 2008-04-09 14:45:42 EDT
I'm trying to set up dual head (Dell 2407WFP 1920x1200 and Dell 2001FP
1600x1200) and though I do have dual head working fine (without compiz :-( ) I
can't get the monitors to each be their native resolutions. They are always are
both 1920x1200 or 1600x1200. I'll include my xorg.conf next. My card is 

05:00.0 VGA compatible controller: ATI Technologies Inc RV370 [Sapphire X550
Silent] (prog-if 00 [VGA controller])
05:00.1 Display controller: ATI Technologies Inc RV370 secondary [Sapphire X550
Silent]

I've tried having no modes, preferredmodes in each monitor definition, just one,
or the other, and I've had no luck. Also if I start restarting X too many times,
it seems to just stop working until I reboot. Can't switch to VT, etc.
Comment 1 Thomas J. Baker 2008-04-09 14:46:35 EDT
I meant to add these details:

raptor> rpm -q xorg-x11-drv-ati
xorg-x11-drv-ati-6.8.0-10.fc9.x86_64
raptor> rpm -q kernel
kernel-2.6.25-0.201.rc8.git4.fc9.x86_64
kernel-2.6.25-0.204.rc8.git4.fc9.x86_64
kernel-2.6.25-0.216.rc8.git7.fc9.x86_64
raptor> cat /proc/version 
Linux version 2.6.25-0.216.rc8.git7.fc9.x86_64 (mockbuild@) (gcc version 4.3.0
20080404 (Red Hat 4.3.0-6) (GCC) ) #1 SMP Wed Apr 9 01:19:32 EDT 2008
raptor> 
Comment 2 Thomas J. Baker 2008-04-09 14:47:23 EDT
Created attachment 301881 [details]
xorg.conf
Comment 3 Thomas J. Baker 2008-04-09 14:47:59 EDT
Created attachment 301882 [details]
Xorg.0.log
Comment 4 Dave Airlie 2008-05-06 21:03:16 EDT
can you re-try with latest server and ati driver..

also please remove the modes bit from the last section, as this is limiting
everyone to that one mode.
Comment 5 Thomas J. Baker 2008-05-07 15:43:53 EDT
Just tried and I'm still having the same problem. If I have just preferredmodes
with each monitor and no modes in the Screen seciton, I get 1600x1200 on each
monitor. I'll include the Xorg log next.
Comment 6 Thomas J. Baker 2008-05-07 15:44:40 EDT
Created attachment 304800 [details]
/var/log/Xorg.0.log.old
Comment 7 Thomas J. Baker 2008-05-07 15:50:04 EDT
To be clear, that Xorg.0.log is from an xorg.conf with appropriate
PreferredModes for each monitor and no modes defined in the Screen section. In
the log it says 

(II) RADEON(0): Using user preference for initial modes
(II) RADEON(0): Output DVI-1 using initial mode 1600x1200
(II) RADEON(0): Output DVI-0 using initial mode 1600x1200

but I'm not clear on why it decides that.
Comment 8 Bug Zapper 2008-05-14 05:12:57 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Thomas J. Baker 2008-05-20 09:12:50 EDT
I just tried the screen resolution caplet which I didn't know got included with
F9 and it allows me to have the screens at the correct resolution once I log in.
So in theory, I should be able to do this from an xorg.conf file, I just need
the right incantation.
Comment 10 Bug Zapper 2009-06-09 20:06:19 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2009-07-14 13:28:26 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.