This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 441749 - firstboot uses kudzu?
firstboot uses kudzu?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 15:12 EDT by Bill Nottingham
Modified: 2014-03-16 23:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 04:19:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-04-09 15:12:17 EDT
+++ This bug was initially created as a clone of Bug #441721 +++

libkudzu doesn't contain the minifind() routine. So, for example, the
additionalcds firstboot module aborts with

ImportError: /usr/lib/python2.5/site-packages/_kudzumodule.so: undefined symbol
minifind

...

I'll fix kudzu, but what is firstboot doing here? pirut had HAL-based CD code.
Comment 1 Chris Lumens 2008-04-09 17:31:13 EDT
Yes, the old old additional_cds module contains CD code as it was never updated
to work with the new way of doing things.  It's not enabled so any kudzu
dependency can be removed, but we'll need to update this module before the next
RHEL rolls out.
Comment 2 Bill Nottingham 2008-04-09 17:43:52 EDT
Apparently it's still imported on firstboot start. Should we not package it for now?
Comment 3 Chris Lumens 2008-04-09 17:55:42 EDT
It's imported because we try to import all modules.  We can just not package it
until a replacement shows up if that helps speed along getting rid of kudzu.
Comment 4 Bill Nottingham 2008-04-09 22:44:48 EDT
Well, the package doesn't require kudzu. So it theoretically could traceback on
a failed import.
Comment 5 Chris Lumens 2008-04-10 04:19:36 EDT
Okay, this will be removed from the next rebuild of firstboot.

Note You need to log in before you can comment on or make changes to this bug.