Bug 441755 - gpk-application hangs on "other" group
Summary: gpk-application hangs on "other" group
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F9PKBlocker
TreeView+ depends on / blocked
 
Reported: 2008-04-09 20:08 UTC by Rahul Sundaram
Modified: 2013-03-13 05:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-01 10:26:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gpk-application crash report (245.66 KB, text/plain)
2008-04-15 18:10 UTC, Rahul Sundaram
no flags Details
gpk-update-icon crash reportgk (194.74 KB, text/plain)
2008-04-15 18:11 UTC, Rahul Sundaram
no flags Details
simple fix (363 bytes, patch)
2008-04-24 03:12 UTC, Matthias Clasen
no flags Details | Diff

Description Rahul Sundaram 2008-04-09 20:08:26 UTC
Description of problem:

Clicking on the "other group" makes gpk-application hang everytime. If you need
more information, let me know. 


Version-Release number of selected component (if applicable):

#rpm -q gnome-packagekit PackageKit

gnome-packagekit-0.1.11-1.fc9.i386
PackageKit-0.1.11-1.fc9.i386


How reproducible:

everytime

Comment 1 Rahul Sundaram 2008-04-09 20:11:06 UTC
A long list of packages showed up soon after I filed this so apparently it is
not a hang but it takes a considerably long time (about a minute) or so with the
application freezing meantime. Either incrementally list the apps or get a
progress bar or both. 

Comment 2 Richard Hughes 2008-04-11 15:29:36 UTC
What does the status bar say when it was frozen? Would the application actually
frozen or just not doing anything? Is this reproducable?

Comment 3 Rahul Sundaram 2008-04-11 15:39:38 UTC
I cant see any part of the application. It is white and looks frozen. It is
reproducible. 

Comment 4 Richard Hughes 2008-04-12 12:31:31 UTC
I'm guessing it's because we are sorting the treeview as the packages are added
(CPU intensive) and that there are so many packages.

Comment 5 Rahul Sundaram 2008-04-12 12:40:54 UTC
When I click on any relatively large group, it constantly refreshes causing a
disturbing flicker for sometime. That should be much more smoother to not cause
a eye sore. 

Comment 6 Richard Hughes 2008-04-15 15:44:43 UTC
Can you please try my git snapshot packages, 0.2.0 as I've merged in a few fixed
for this. If it works, i'll drag then into stable. Thanks.

Comment 7 Rahul Sundaram 2008-04-15 18:10:41 UTC
Created attachment 302500 [details]
gpk-application crash report

crash after updating to the latest utopia repo version

Comment 8 Rahul Sundaram 2008-04-15 18:11:51 UTC
Created attachment 302501 [details]
gpk-update-icon crash reportgk

gpk update icon crashed on relogin

Comment 9 Richard Hughes 2008-04-17 09:06:43 UTC
Did you update gnome-packagekit and PackageKit at exactly the same time?

Comment 10 Rahul Sundaram 2008-04-17 13:07:17 UTC
I did a yum update. I think that's just the same time. Do you want me to try
something else now?

Comment 11 Matthias Clasen 2008-04-24 03:11:41 UTC
Still seeing this issue with gnome-packagekit-0.1.12-7.20080423.fc9.i386.

Here is a lo-tech fix that makes the ui responsive while the bazillion package
callbacks are flowing in.

Comment 12 Matthias Clasen 2008-04-24 03:12:23 UTC
Created attachment 303567 [details]
simple fix

Comment 13 Will Woods 2008-04-25 19:31:24 UTC
Unfixed in PackageKit-0.1.12-7.20080425.fc9, AFAICT.

Comment 14 Robin Norwood 2008-04-26 03:46:56 UTC
Fixed upstream in commit 7eba0aeb62237858c7316fa9a4c60e6209019d89

Comment 15 Richard Hughes 2008-04-26 09:22:57 UTC
Yup, please push to stable also, thanks.

Comment 16 Richard Hughes 2008-04-30 15:33:43 UTC
Just building this as http://koji.fedoraproject.org/koji/taskinfo?taskID=590353


Note You need to log in before you can comment on or make changes to this bug.