Bug 441764 - Firefox crashes when extensions manager is shown or extensions are updated
Firefox crashes when extensions manager is shown or extensions are updated
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 17:22 EDT by John Chivall
Modified: 2008-04-17 07:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 05:36:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb backtrace as requested (19.04 KB, text/plain)
2008-04-10 16:53 EDT, John Chivall
no flags Details

  None (edit)
Description John Chivall 2008-04-09 17:22:43 EDT
Description of problem:

In Firefox 3 beta 5 in Gnome 2.22 on Fedora 9 beta (rawhide), opening the "add-
ons" window, attempting to install an extension or even firefox automatically 
checking for updates causes an instant silent crash.

Version-Release number of selected component (if applicable):
3.0b5

How reproducible:
Always

Steps to Reproduce:
1. Start firefox
2. Click Tools -> Add-ons...
3. Crash.

or

1. Update firefox
2. Start firefox
3. Firefox checks for updates to extensions -> Crash.
  
Actual results:
Firefox is unusable as it crashes almost immediately after start as it checks 
for updates to extensions.

Expected results:
Firefox doesn't crash.

Additional info:
Firefox -d does nothing (hangs?) so can't provide any more info.
Comment 1 Martin Stransky 2008-04-09 17:31:47 EDT
You can attach gdb to already running firefox process. run $gdb --pid=xxx where
xxx is a pid of firefox-bin
Comment 2 John Chivall 2008-04-09 17:38:19 EDT
Forgot to say: This happens with a new, clean mozilla profile as well as my 
usual one.
Comment 3 John Chivall 2008-04-09 18:20:01 EDT
Sorry, haven't got debuginfo installed for anything, 240M download, will have 
to wait for another day. This is what I get from gdb:

(no debugging symbols found)
0x00110416 in __kernel_vsyscall ()
(gdb) continue
Continuing.
[New Thread 0xb39e9b90 (LWP 3803)]
[New Thread 0xb2fc7b90 (LWP 3804)]
[New Thread 0xb25c6b90 (LWP 3805)]
[New Thread 0xb1bc5b90 (LWP 3806)]
[New Thread 0xb11c4b90 (LWP 3807)]
[Thread 0xb25c6b90 (LWP 3805) exited]
[Thread 0xb1bc5b90 (LWP 3806) exited]
[Thread 0xb39e9b90 (LWP 3803) exited]
[Thread 0xb11c4b90 (LWP 3807) exited]
[Thread 0xb6937b90 (LWP 3740) exited]
[New Thread 0xb6937b90 (LWP 3820)]
(no debugging symbols found)

Program received signal SIGILL, Illegal instruction.
[Switching to Thread 0xb80476d0 (LWP 3732)]
0x015641ff in ?? () from /usr/lib/xulrunner-1.9pre/libxul.so
(gdb) Quit
(gdb) 
Continuing.
[Thread 0xb2fc7b90 (LWP 3804) exited]

Program received signal SIGILL, Illegal instruction.
0x00110416 in __kernel_vsyscall ()

Looks like xulrunner may be the culprit? I'll post more info once I've got the 
debug info installed.
Comment 4 John Chivall 2008-04-09 18:42:20 EDT
### Firefox is showing "your last session closed unexpectedly". Clicked 
"restore" (clicking "new session" has same effect" ####
0x00110416 in __kernel_vsyscall ()
Missing separate debuginfos, <snipped>
(gdb) continue
Continuing.
[Thread 0xb6948b90 (LWP 6772) exited]
[New Thread 0xb6948b90 (LWP 6779)]
[New Thread 0xb3a3bb90 (LWP 6780)]
[New Thread 0xb303ab90 (LWP 6781)]
[Thread 0xb6948b90 (LWP 6779) exited]
[Thread 0xb3a3bb90 (LWP 6780) exited]
[New Thread 0xb2639b90 (LWP 6782)]
[Thread 0xb303ab90 (LWP 6781) exited]
[New Thread 0xb6948b90 (LWP 6783)]
[New Thread 0xb3a3bb90 (LWP 6784)]
[Thread 0xb3a3bb90 (LWP 6784) exited]
[New Thread 0xb3a3bb90 (LWP 6785)]
[Thread 0xb2639b90 (LWP 6782) exited]
[New Thread 0xb2639b90 (LWP 6786)]
[New Thread 0xb303ab90 (LWP 6787)]
[Thread 0xb303ab90 (LWP 6787) exited]
[Thread 0xb2639b90 (LWP 6786) exited]

Program received signal SIGILL, Illegal instruction.
[Switching to Thread 0xb80586d0 (LWP 6763)]
fbCompositeSrc_8888x8888mmx (op=Could not find the frame base for 
"fbCompositeSrc_8888x8888mmx".
) at /usr/lib/gcc/i386-redhat-linux/4.3.0/include/mmintrin.h:63
63	  return (__m64) __builtin_ia32_vec_init_v2si (__i, 0);
(gdb) 
             ###  firefox is now displaying main window and add-ons window 
showing updated language packs from latest firefox package update ###

Continuing.

Program received signal SIGILL, Illegal instruction.
0x00110416 in __kernel_vsyscall ()
(gdb) 
Continuing.

Program terminated with signal SIGILL, Illegal instruction.
The program no longer exists.
(gdb) 


Hope this helps.
Comment 5 Matěj Cepl 2008-04-10 13:42:51 EDT
Sorry, but this is not complete. Please, do the same what you did to reproduce
the previous gdb records, and when you get to (gdb) prompt run command

thread apply all backtrace

and attach THAT huge result to the comment of this bug.

Thank you
Comment 6 John Chivall 2008-04-10 16:53:24 EDT
Created attachment 302072 [details]
gdb backtrace as requested

Sorry, not filed a bug before. Anything else you need?
Comment 7 Martin Stransky 2008-04-11 04:41:19 EDT
Seems to be a crash in cairo/pixman, Illegal instruction... 
You have a processor with MMX support, right? ;-)
Comment 8 John Chivall 2008-04-12 04:54:27 EDT
Should do:

$ cat /proc/cpuinfo 
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 6
model		: 4
model name	: AMD Athlon(tm) Processor
stepping	: 2
cpu MHz		: 1194.984
cache size	: 256 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat 
pse36 mmx fxsr syscall mmxext 3dnowext 3dnow up
bogomips	: 2390.90
clflush size	: 32
Comment 9 Sitsofe Wheeler 2008-04-16 17:53:44 EDT
I have seen this to with F9 Beta (and again it is reproducible every time). My
machine is also an old style Athlon:

processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 4
model name      : AMD Athlon(tm) Processor
stepping        : 2
cpu MHz         : 850.068
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat
pse36 mmx fxsr syscall mmxext 3dnowext 3dnow up
bogomips        : 1702.02
clflush size    : 32
Comment 10 John Chivall 2008-04-17 05:29:34 EDT
Appears to be fixed in latest update: firefox-3.0-0.54.beta5.fc9.i386
xulrunner-1.9-0.54.beta5.fc9.i386
Thanks!
Comment 11 Martin Stransky 2008-04-17 05:36:39 EDT
okay, closing.
Comment 12 Sitsofe Wheeler 2008-04-17 07:39:03 EDT
I can confirm the latest update resolves the issue (I guess it is down to this:
* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
- Re-enable system cairo

Note You need to log in before you can comment on or make changes to this bug.