Bug 441774 - Anaconda crashes after formatting disk, when installing from NFS
Summary: Anaconda crashes after formatting disk, when installing from NFS
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: NeedsRetesting
Keywords:
Depends On:
Blocks: F9PR
TreeView+ depends on / blocked
 
Reported: 2008-04-09 22:44 UTC by Deepak Bhole
Modified: 2008-04-12 22:19 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 22:10:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda traceback (53.25 KB, text/plain)
2008-04-09 22:44 UTC, Deepak Bhole
no flags Details

Description Deepak Bhole 2008-04-09 22:44:36 UTC
Description of problem:
Anaconda crashes just after formatting, just when it is about to start install.

Version-Release number of selected component (if applicable):
11.4.0.66

How reproducible:
Always

Steps to Reproduce:
1. Boot from boot.iso
2. Select english/english for language and keyboard
3. Select dhcp for network
4. Select Network for install, and provide NFS directory that has media files
5. Select timezone, set machine name, root pw, auto/default partition creation,
and hit next
  
Actual results:
Anaconda crashes with a traceback right after formatting

Expected results:
Anaconda should proceed with the install

Additional info:

I am attaching the traceback file with this bug. The machine name and path have
been replaced with a generic name/location.

Comment 1 Deepak Bhole 2008-04-09 22:44:36 UTC
Created attachment 301906 [details]
anaconda traceback

Comment 2 Jesse Keating 2008-04-10 01:06:51 UTC
Hrm, I saw this too, and I think Chris is fixing it by mounting NFS in stage1
and just keeping it mounted.  This should be fixed in tomorrows rawhide.

Comment 3 Chris Lumens 2008-04-10 08:22:29 UTC
Yes that is just what I did, though I was unable to test it.  Should be pretty
straightforward though.

Comment 4 Deepak Bhole 2008-04-10 22:10:18 UTC
Okay, looks like it has been fixed now. I can no longer reproduce it in today's
rawhide (Anaconda 11.4.0.70). I will close the bug once it is set to RESOLVED.

Comment 5 Deepak Bhole 2008-04-10 22:12:08 UTC
Doh! mistakenly marked it as CLOSED NOT A BUG without realizing :( 

Anyways, I am fine with leaving it this way now that the issue is resolved. Feel
free to re-open and mark resolved if needed for tracking purposes, and I will
close then.


Note You need to log in before you can comment on or make changes to this bug.