Bug 441796 - new gdm needs translation updates
new gdm needs translation updates
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: MoveUpstream, Translation
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2008-04-10 02:49 EDT by Jens Petersen
Modified: 2015-01-14 18:20 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 01:44:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-04-10 02:49:39 EDT
Description of problem:
gdm needs its translations updated after its major rewrite.
Damned Lies also says there are a couple of files missing from the POT files list.
Comment 2 Runa Bhattacharjee 2008-04-10 07:18:33 EDT
Hi,
Are the translations, to make into F9 or F10? 

For F9/gnome-2.22, the updated translations are in the gnome-2-20 branch:

http://svn.gnome.org/viewvc/gdm/branches/gnome-2-20/po/?sortby=date#dirlist
Comment 3 Jens Petersen 2008-04-11 01:14:30 EDT
(In reply to comment #2)
> Are the translations, to make into F9 or F10? 

Thanks.  Ideally both but I guess it is too late for F9 final now.
Perhaps they could go into an update?  But we certainly need
them for gnome-2.24/F10.
Comment 4 Runa Bhattacharjee 2008-04-11 03:00:53 EDT
As per the damned lies page for gdm on l10.gnome.org the statistics for the POT
files vary widely and indicate that the message templates provided for
translations as well as the translations that have been packaged are out of sync.

Pot file statistics:
================
HEAD: 213 messages
http://l10n.gnome.org/module/gdm#HEAD

branch gnome-2-20 (indicated to be the branch used for the  gnome 2.22 stable
release):  897 messages
http://l10n.gnome.org/module/gdm#gnome-2-20

The following is the statistics for a few languages, found in the po folder of
gdm-2.21.9 :
http://ftp.acc.umu.se/pub/GNOME/sources/gdm/2.21/

bn_IN.po
657 translated messages, 121 untranslated messages.
as.po
132 translated messages
gu.po 
970 translated messages.
hi.po 
778 translated messages.
te.po 
111 translated messages, 15 fuzzy translations, 100 untranslated messages.
kn.po 
204 translated messages, 1 fuzzy translation, 17 untranslated messages.
mr.po 
223 translated messages.
ja.po 
961 translated messages.
fr.po 
225 translated messages, 1 untranslated message
it.po 
30 translated messages, 54 fuzzy translations, 48 untranslated messages.

Please note, that the total number of messages for the <lang>.po files vary widely.

There was some discussion about the inconsistency about gdm messages on the
gnome-i18n list earlier when gdm module was going through an overhaul.

http://mail.gnome.org/archives/gnome-i18n/2007-November/msg00017.html

Hope this helps.
Comment 5 Matthias Clasen 2008-04-11 10:44:05 EDT
I've updates the POTFILES.in in upstream svn to include the missing files.
Comment 6 Bug Zapper 2008-05-14 05:13:44 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Jens Petersen 2008-07-02 05:32:37 EDT
Ok, I see about 18 languages have been updated since 11 April,
but many key languages are still missing...
Comment 8 Tony Fu 2008-09-09 23:06:25 EDT
requested by Jens Petersen (#27995)
Comment 9 Ville-Pekka Vainio 2008-11-29 13:12:21 EST
If at all possible, please pull in updated translations from GNOME SVN. I'm using the Finnish translation (fi.po) and the po file shipped with Fedora 10's gdm-2.24.0-12.fc10.i386 has only 182 messages when http://l10n.gnome.org/POT/gdm.HEAD/gdm.HEAD.fi.po has 241 messages.

There's also a translation bug fixed in the current fi.po. "Restart" was translated incorrectly into Finnish as "Restart GDM". That has been fixed in GNOME SVN.
Comment 10 Ville-Pekka Vainio 2009-02-07 08:55:27 EST
It seems at least the Finnish translation is updated in the current Rawhide gdm package, but I won't close this, since I'm not sure about other languages.
Comment 11 Jens Petersen 2009-02-16 23:55:15 EST
Japanese is still not updated anyway but that may be the ongoing upstream issue.
Comment 12 Jens Petersen 2009-02-17 03:49:52 EST
Noriko, I tried to get movement from upstream Japanese l10n on this a while back and still see no update.
This situation has been persisting since gdm was rewritten some releases ago...

Are or someone in Fedora l10n able to help get the Japanese (and maybe other) translations updated?
Comment 13 Igor Pires Soares 2009-02-28 13:22:44 EST
We really need to get this solved for Fedora 11.

The F10 version of Fedora's gdm is missing some translated strings for Brazilian Portuguese too, although the upstream version was fully translated in time for GNOME 2.24.

The same is about to happen with F11 and GNOME 2.26. A fix for this would be highly appreciated.
Comment 14 Noriko Mizumoto 2009-03-02 03:30:12 EST
The issue of 'Japanese and other languages translation are not updated'.
=> Each Fedora team (and Red Hat internal team together) needs to work with corresponding Gnome teams. The mail will be posted in f-t-l once the below is cleared.

The issue of 'F10 version with GNOME2.24 of Fedora's gdm is missing some translated strings even the upstream version of GNOME2.24 has been fully translated on time'
=> Who will be the person in charge to pull 2.26 in for F11? What is the process?
Comment 15 Noriko Mizumoto 2009-03-10 19:56:14 EDT
Most of popular languages have now been updated to 100% or close to 100% in HEAD.  The deadline is 13-Mar, thus those translation should all be included in GNOME2.26 (fi,pt_BR,ja,es,fr,it,ko_KR,de=100%, ru=93%, zh_TW,zh_CN=98% as at 11-Mar. every po file has same total 236 messages).
http://l10n.gnome.org/module/gdm/

Description of problem:
The F10 version of Fedora's gdm is missing some translated strings, although the upstream version was fully translated in time for GNOME 2.24..

Version-Release number of selected component (if applicable):
F9, F10 and up-coming F11 versions

How reproducible:
Always

Actual results:
Missing translated strings

Expected results:
F11 gdm have translated strings of GNOME2.26
Comment 16 Jens Petersen 2009-03-16 05:52:20 EDT
Please!
Comment 17 Jens Petersen 2009-03-31 01:35:23 EDT
Looks good now for ja - thanks :)

Note You need to log in before you can comment on or make changes to this bug.