Bug 441812 - opensc should BuildRequires libassuan-devel
opensc should BuildRequires libassuan-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: opensc (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 06:26 EDT by Patrice Dumas
Modified: 2008-04-10 11:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 11:02:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2008-04-10 06:26:00 EDT
Description of problem:

As Summary says. It may make sense to BuildRequires also 
libassuan-static to be sure that build breaks when libassuan-static
is removed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hans de Goede 2008-04-10 08:11:05 EDT
Erm,

opensc already BuildRequires libassuan-static, which is provided by
libassuan-devel, closing.
Comment 2 Patrice Dumas 2008-04-10 09:47:34 EDT
Sure, it works, but libassuan-static is not meant to provide the development
bits needed to build against libassuan. Depending on the -devel subpackages
corresponds with the intention to link against libassuan, while depending on the
-static subpackage means that opensc needs static libraries which I think is not
true.

This is not a very problematic bug, since the end result is the same, but I
think that it is important to be consistent and have meaningful requires, not
only correct requires.

For example (and that's how I noticed it), one may want to know what links
against libassuan for any reason, one being for example that there was a rebuild
and all the dependent packgages should be rebuilt too. In that case, the logical
repoquery call is

repoquery --archlist=src --whatrequires libassuan-devel

While if one want to know which packages in fedora requires static libs one
would do something like
repoquery --archlist=src --whatrequires '*-static' 
and opensc will wrongly appear as requiring a static libassuan library while
it only needs to link against libassuan.
Comment 3 Patrice Dumas 2008-04-10 09:49:31 EDT
Also it is implied by the guidelines (though in that sort of areas I don't think
that guidelines should necessarily be followed to the letter):

"This way other packages which will link against a dynamic library when your 
package starts providing one can BuildRequire: foo-devel and packages which
explicitly need to link against the static version can BuildRequire: foo-static"
Comment 4 Hans de Goede 2008-04-10 09:59:33 EDT
Ah, so you want me to change the BuildRequires from libassuan-static to
libassuan-devel. Sure I can do that, next time it would help though if you would
spend a litle bit more time explaining yourself in your initial bug report.
"As Summary says" isn't exactly crystal clear, and the sentence after that only
lead to more confusion on my side.
Comment 5 Patrice Dumas 2008-04-10 10:12:01 EDT
Indeed I was unclear, but I cannot promise honestly that I'll be clearer in the
future... I always try to be clear, but it is often unsuccessful.
Comment 6 Hans de Goede 2008-04-10 11:02:15 EDT
Fixed in rawhide, it may not show up until the freeze is over!

Note You need to log in before you can comment on or make changes to this bug.