Bug 441813 - fails to parse Short-Description in LSB header
fails to parse Short-Description in LSB header
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: chkconfig (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 06:33 EDT by Peter Eisentraut
Modified: 2014-03-16 23:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 15:55:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the problem (830 bytes, patch)
2008-04-10 06:34 EDT, Peter Eisentraut
no flags Details | Diff

  None (edit)
Description Peter Eisentraut 2008-04-10 06:33:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux; de) KHTML/3.5.9 (like Gecko) (Debian)

Description of problem:
When calling chkconfig with an init script that only contains 
Short-Description but no Description in the LSB header, chkconfig complains 
that the script does not support chkconfig.  This is because chkconfig fails 
to parse the Short-Description header due to an obvious programming error; see 
my attached patch.

Version-Release number of selected component (if applicable):
chkconfig-1.3.37-2

How reproducible:
Always


Steps to Reproduce:
1. Install an init script with Short-Description but without Description
2. Call chkconfig


Actual Results:
The affected init scripts are missing from the list.

Expected Results:
The affected init scripts should be included in the list.

Additional info:
Comment 1 Peter Eisentraut 2008-04-10 06:34:34 EDT
Created attachment 301961 [details]
Patch to fix the problem
Comment 2 Bug Zapper 2008-05-14 05:14:11 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bill Nottingham 2008-12-04 15:55:09 EST
Added in git, will be in 1.3.40-1.

http://git.fedorahosted.org/git/?p=chkconfig.git;a=commitdiff;h=877998e21d8d8201e6b2bbdbed6095004d903a84

Note You need to log in before you can comment on or make changes to this bug.