Bug 441814 - nget should build against uulib-devel, not uulib-static
nget should build against uulib-devel, not uulib-static
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nget (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 06:38 EDT by Patrice Dumas
Modified: 2008-09-06 13:26 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-06 13:26:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2008-04-10 06:38:21 EDT
Description of problem:

If there is a compelling reason, please tell it here and if it is really
compelling, a comment should be added in the spec file.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrice Dumas 2008-04-10 10:14:34 EDT
To be more precise, depending on the -devel subpackages corresponds with the
intention to link against the library, while depending on the -static subpackage
means that nget needs the uulib static libraries which I think is not true.

This is not a very problematic bug, since the end result is the same, but I
think that it is important to be consistent and have meaningful requires, not
only correct requires.

Also it is implied by the guidelines (though in that sort of areas I don't think
that guidelines should necessarily be followed to the letter):

"This way other packages which will link against a dynamic library when your 
package starts providing one can BuildRequire: foo-devel and packages which
explicitly need to link against the static version can BuildRequire: foo-static"

Comment 2 Debarshi Ray 2008-05-12 23:10:00 EDT
uulib-static comes from the uudeview package, which only provides static
archives and no dynamic library. I see that you have changed the package name to
uulib-devel, which has 'Provides: uulib-static', after filing this bug.

The reason I preferred -static over -devel is that I did not want to slip in a
dependency on some static library in the garb of of yet another -devel package.
Comment 3 Bug Zapper 2008-05-14 05:14:17 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Debarshi Ray 2008-06-02 13:52:43 EDT
Ping?
Comment 5 Debarshi Ray 2008-09-06 13:26:45 EDT
I am closing this as WONTFIX. Please feel free to reopen if you have further doubts or issues. Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.