Bug 441817 - segfault on downgrade, repository
segfault on downgrade, repository
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tog-pegasus (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Vitezslav Crhonek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 07:23 EDT by Chris Ward
Modified: 2009-04-30 08:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-30 08:25:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
partial tog-pegasus downgrade strace (14.25 MB, text/plain)
2008-04-10 07:23 EDT, Chris Ward
no flags Details
proposed patch for tog-pegasus 2.6.1 (1.36 KB, patch)
2009-04-23 08:10 EDT, Vitezslav Crhonek
no flags Details | Diff

  None (edit)
Description Chris Ward 2008-04-10 07:23:54 EDT
Description of problem:
When I downgrade tog-pegasus from version tog-pegasus-2.7.0-2.el5 (shipping with
RHEL 5.2) I get a segfault in the process. Everything downgrades fine, in terms
of package installation, however i'm concerned of course by the fact there is a
segfault at all. It seems the issue stems from the repository downgrade.

I'm not sure of the implications of this, but the segfault be corrected.

If I first remove /var/lib/Pegasus/repository/, then downgrade, no segfault occurs.

strace output is attached.

Version-Release number of selected component (if applicable):
tog-pegasus-2.7.0-2.el5

How reproducible:
always

Steps to Reproduce:
1.downgrade, for example, from tog-pegasus-2.7.0-2.el5 to
tog-pegasus-2.6.1-2.el5_1.1

Actual results:
segfault during repo downgrade

Expected results:
no segfault
Comment 1 Chris Ward 2008-04-10 07:23:57 EDT
Created attachment 301966 [details]
partial tog-pegasus downgrade strace
Comment 3 Vitezslav Crhonek 2009-03-17 10:54:20 EDT
It doesn't occur when downgrading from 2.7.x to 2.7.y or from 2.6.x to 2.6.y.

I was not able to find exact statement in the documentation, but I believe that repositories are not backward-compatible between major releases.
Comment 4 Vitezslav Crhonek 2009-04-23 08:10:25 EDT
Created attachment 340930 [details]
proposed patch for tog-pegasus 2.6.1
Comment 5 Vitezslav Crhonek 2009-04-23 09:06:19 EDT
The issue is not present in tog-pegasus 2.7.x branch (which is shipped in RHEL5) - it's fixed by upstream.
Comment 7 RHEL Product and Program Management 2009-04-30 08:25:20 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.