Bug 441822 - verbosity option of ecryptfs mount helper not recognized
verbosity option of ecryptfs mount helper not recognized
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ecryptfs-utils (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 09:14 EDT by Jan Tluka
Modified: 2009-01-20 16:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:59:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Tluka 2008-04-10 09:14:23 EDT
Description of problem:
Case 1:
There seems to be a mixture of 'verbose' and 'verbosity' option of
mount.ecryptfs command. 'man ecryptfs' says that verbosity option is used to get
more verbose output from ecryptfs mount helper in system logs. When I use
'verbosity=1' the output in syslog is still the same. When I use 'verbose=1'
instead syslog is filled with a lots of information from ecryptfs.

Case 2:
Furthermore I've been using 'verbosity=0' to stop mount helper from prompting me
when all required options (key method, passwd, cipher, key_bytes) are specified
in the option list and use defaults for the rest (plaintext passthrough, xattr).
If I don't use this option I'm being asked for plaintext passthrough which
should be off by default. Also following message is written in syslog:
ecryptfs_parse_options: eCryptfs: unrecognized option 'verbosity=0'

Version-Release number of selected component (if applicable):
ecryptfs-utils-41-1.el5

How reproducible:
100%

Steps to Reproduce:
0. look at man pages - search for 'verbosity' option
Do following as root:

Case 1: verbosity/verbose mixture
just mount with these commands and compare /var/log/messages output ...
# mount -t ecryptfs .secret .secret -o 
key=passphrase:passwd=secret,ecryptfs_cipher=aes,ecryptfs_key_bytes=16,no_sig_cache,verbosity=1
-- not lots of information in /var/log/messages
-- and unrecognized option verbosity in logs ...
# mount -t ecryptfs .secret .secret -o 
key=passphrase:passwd=secret,ecryptfs_cipher=aes,ecryptfs_key_bytes=16,no_sig_cache,verbose=1
-- LOTS of information from ecryptfs in /var/log/messages

Case 2: verbosity=0 influences further prompts ...
# mount -t ecryptfs .secret .secret -o 
key=passphrase:passwd=secret,ecryptfs_cipher=aes,ecryptfs_key_bytes=16,no_sig_cache
-- prompt for plaintext passthrough (why? when it's off by default)
# mount -t ecryptfs .secret .secret -o 
key=passphrase:passwd=secret,ecryptfs_cipher=aes,ecryptfs_key_bytes=16,no_sig_cache,verbosity=0
-- no prompt and fs mounted, but /var/log/messages shows that the option is not
recognized!

Actual results:
included in test cases

Expected results:
Case 1: 
man pages should change word 'verbosity' to 'verbose'

Case 2:
Prompt for 'plaintext passthrough' is not shown when all required options are
specified. If user wants that feature he has to specify that explicitly.
The 'verbosity' option should be removed and should not influence mount helper
behaviour.
Comment 1 Phil Knirsch 2008-04-28 08:49:25 EDT
Sounds like another doable fix.

Proposing for RHEL-5.3 and granting Devel ACK.

Read ya, Phil
Comment 2 Phil Knirsch 2008-05-14 10:00:02 EDT
Proposing bug for RHEL-5.3 FasTrack.

Read ya, Phil
Comment 4 Karsten Hopp 2008-05-30 12:49:10 EDT
Case 1: verbose isn't the same as verbosity. verbosity takes an argument, 
        verbose always switches verbose output on and verbose=0 is the same 
        as verbose=1 or verboseXXXX
        verbosity=1 isn't parsed anywhere in the sources
Case 2: Here are several bugs:
   - verbosity isn't removed from the list of options passed to systems mount 
     command. This causes the 'unrecognized option' error.
   - verbosity=0 apparently does the same as no_sig_cache, this looks like a
     cut¬paste error in the sources. I still need to look why and where it
     turns of the prompts, though
Comment 5 Kevin Krafthefer 2008-06-06 13:34:59 EDT
approved comp, clearing fast flag
Comment 10 Karsten Hopp 2008-10-29 08:10:24 EDT
I think I need to clarify this:

mount.ecryptfs has two distinct parameters 'verbose' and 'verbosity={0,1}'

'verbose' enables a very verbose logging in /var/log/messages and shouldn't 
be used in production environments unless you're debugging something.

'verbosity=0' uses default values for required parameters which aren't specified
 on the commandline, p.e. it doesn't ask for 'plaintext passthrough (y/n)' anymore
 with the commandline from comment #7 and just uses plaintext passthrough.

'verbosity=1' asks for every required parameter which hasn't been specified on 
the commandline. That's the same as not using the verbosity option at all.

Older versions had a bug which passed the verbosity option to /sbin/mount instead
of keeping it in /sbin/mount.ecryptfs. This resulted in a message 
"ecryptfs_parse_options: eCryptfs: unrecognized option 'verbosity=0'" in the
 syslog. This is fixed in our current package.

Nonetheless there's a bug in the current package which misinterpretes
 'verbosity=1' to be the same as 'verbose'. This needs to be fixed and 
I already have a patch for that.
Comment 17 errata-xmlrpc 2009-01-20 16:59:47 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0203.html

Note You need to log in before you can comment on or make changes to this bug.