This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 441836 - Test page does not honor page size
Test page does not honor page size
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2008-04-10 10:23 EDT by Christoph Wickert
Modified: 2008-07-26 02:09 EDT (History)
0 users

See Also:
Fixed In Version: 0.7.82.3-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-17 18:27:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
PPD of A5 printer using "Generic PCL 6/PCL XL Printer Foomatic/pxlmono" (13.53 KB, text/plain)
2008-04-10 11:30 EDT, Christoph Wickert
no flags Details

  None (edit)
Description Christoph Wickert 2008-04-10 10:23:42 EDT
Description of problem:
Test page is always printed in "A4" or "Letter", even if user selects a
different page size.

Version-Release number of selected component (if applicable):
system-config-printer-0.7.74.11-4.fc8

How reproducible:
always

Steps to Reproduce:
1. set up a new printer with page size A5 for example
2. Print Test page
3. The s-c-p prints A4 test page
  
Actual results:
Because the printer does not only print to the paper but also to the transport
rolls it is broken afterwards. A4 pages now have massive relicts of the test
page. If it's an ink printer you are lucky and "only" need to clean it
completely. But if it's a laser printer this is getting expensive: it need 2
transport rolls and a complete drum unit. :(

Expected results:
Test page should honor page settings and shouldn't ruin peoples printers.
Comment 1 Tim Waugh 2008-04-10 10:31:17 EDT
Pretty sure this is a CUPS issue.  Could you attach the PPD for the printer
you've configured as A5 please?  That way I can test how the CUPS testprint.ps
PostScript behaves in that case.  Thanks.
Comment 2 Christoph Wickert 2008-04-10 11:29:05 EDT
(In reply to comment #1)
> Pretty sure this is a CUPS issue.

Yes, I think it's a CUPS issue. but s-c-p should at least print out a warning if
testpage doesn't match page size setting.

> Could you attach the PPD for the printer
> you've configured as A5 please?  

Will do. 

> That way I can test how the CUPS testprint.ps
> PostScript behaves in that case.  Thanks.

But be carefull...
Comment 3 Christoph Wickert 2008-04-10 11:30:12 EDT
Created attachment 302010 [details]
PPD of A5 printer using "Generic PCL 6/PCL XL Printer Foomatic/pxlmono"
Comment 4 Tim Waugh 2008-04-10 11:52:53 EDT
Thanks.  The idea is that testprint.ps adjusts its drawing size to the
destination page size, so it should always be fine to print that file regardless
of page size.  Seems like its automatic adjustment is not working in this case
though.
Comment 5 Tim Waugh 2008-04-15 10:49:51 EDT
Thanks.  Please attach /etc/cups/printers.conf, and let me know which queue you
are printing to.
Comment 6 Christoph Wickert 2008-04-15 12:11:06 EDT
After taking a closer look at /etc/cups/printers.conf I realized that it had
still A4 in there:

<Printer HL2070N-A5>
Info Brother HL2070N Laserdrucker
Location Flur
DeviceURI socket://192.168.65.2:9100
State Idle
StateTime 1207839808
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
Option finishings 3
Option job-priority 50
Option media A4
Option number-up 1
Option copies 1
Option orientation-requested 3
Option job-hold-until no-hold
</Printer>

After changing media to A5 in Job Options -> Common Options -> More the test
page is printed correctly, so this is no cups issue. Nevertheless I think that
s-c-p should

- check if Printer Options -> Page Size matches Job Options -> Media or
- set Media to Page Size by default/when Page Size is changed

because the Media option is hidden pretty well in the UI.
Comment 7 Tim Waugh 2008-04-15 13:00:59 EDT
I think what originally happened was that you used the 'Copy' function in
system-config-printer, and that accidentally set all those job options.  I've
fixed that bug today (note to self: branches/0.7.74.x revision 2333).

It's pretty awkward to get Printer Options->Page Size and Job Options->Media to
work right.  There may not be a Printer Options->Page Size option at all, or it
may have a different name.  The list of page sizes may give different names to
the same paper sizes, or have page sizes missing in one list compared to the other.

Unfortunately CUPS *always* provides Job Options->Media to us and we can't tell
whether it is user-set, so we have to display it. :-((
Comment 8 Christoph Wickert 2008-04-15 13:32:08 EDT
(In reply to comment #7)
> I think what originally happened was that you used the 'Copy' function in
> system-config-printer, and that accidentally set all those job options.  I've
> fixed that bug today (note to self: branches/0.7.74.x revision 2333).

Thanks. This has nothing to do with the 'Cops' function and also affects
printers added manually. All Printers are added with A4 (at least with my
locale) and most users will only see the "Page Size" field.

> It's pretty awkward to get Printer Options->Page Size and Job Options->Media to
> work right.  There may not be a Printer Options->Page Size option at all, or it
> may have a different name.  The list of page sizes may give different names to
> the same paper sizes, or have page sizes missing in one list compared to the
other.

Agreed. I have seen 'BrA4' with some Brother Printers and other names.

> Unfortunately CUPS *always* provides Job Options->Media to us and we can't tell
> whether it is user-set, so we have to display it. :-((

I'm afraid we have to, although the UI looks cleaner without. But I'm sure there
are other people out there who did what I did, so it's not really (l)user
friendly atm. ;)
Comment 9 Tim Waugh 2008-04-15 17:07:17 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > I think what originally happened was that you used the 'Copy' function in
> > system-config-printer, and that accidentally set all those job options.  I've
> > fixed that bug today (note to self: branches/0.7.74.x revision 2333).
> 
> Thanks. This has nothing to do with the 'Copy' function and also affects
> printers added manually.

Can you explain what you mean?  The problem is that a Job Options->Media option
was explicitly set -- are you saying you accidentally did this yourself?  I saw
that there are several such options with explicitly-set values, and today I
discovered a bug in system-config-printer's 'Copy printer' code that would lead
to that happening for the copied printer.  That's why I think it might be that bug.

If you definitely didn't use that 'Copy' button, did you set the options
yourself, or do we need to look for some other bug that caused them to be set?

Note that Job Options->Media may be (a) set to some value, or (b) unset; the
problem we are seeing here only occurs for case (a).  Normally there is no
option set [case (b)], and in this case adjusting only the Printer Options->Page
Size option (if such an option exists) will correctly set the actual page size
used by submitted jobs.
Comment 10 Christoph Wickert 2008-04-15 19:41:39 EDT
(In reply to comment #9)
> I saw
> that there are several such options with explicitly-set values, and today I
> discovered a bug in system-config-printer's 'Copy printer' code that would lead
> to that happening for the copied printer.  That's why I think it might be that
bug.

You are correct: I retested and the problem only appeared when I copied a
printer, not when I added it. When I add a new printer and set page size to A5,
Media Source is A5 to in GUI and not written in printers.conf.

> If you definitely didn't use that 'Copy' button, did you set the options
> yourself, or do we need to look for some other bug that caused them to be set?

Seems like old/incompatible options are not deleted when the driver is changed.
Example:
1. Add a printer with the 'Generic PCL 6/PCL XL Printer Foomatic/pxlmono' driver.
2. Change page size to A5 and media to somthing different. Apply, so the
explicitly-set 'Option media ..' will be written.
3. Change media back to A5, Apply.
4. Now change the printer model in s-c-p to 'Generic PCL 6/PCL XL Printer
Foomatic/gutenprint-ijs-simplified.5.0' or 'Generic PCL 6/PCL XL Printer
Foomatic/gutenprint-ijs.5.0'.
5. Page Size now is A4 and we cannot select A5 with this driver in page size nor
in media.
6. But we still have 'Option media A5' in printers.conf.
7. In Job Options -> More Media is empty, so a user wont see the error.
Comment 11 Tim Waugh 2008-04-18 10:18:47 EDT
Copy-printer bug fixed in system-config-printer-0.7.74.12-1.fc8.  Not pushing
for update until problem in comment #10 has been investigated.
Comment 12 Tim Waugh 2008-04-18 11:10:33 EDT
Fixed in revision 2355.  Now we reset the 'media' option in that case.
Comment 13 Fedora Update System 2008-04-18 11:42:02 EDT
system-config-printer-0.7.74.12-2.fc8 has been submitted as an update for Fedora 8
Comment 14 Fedora Update System 2008-04-22 18:44:03 EDT
system-config-printer-0.7.74.12-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-3272
Comment 15 Fedora Update System 2008-05-09 10:47:26 EDT
system-config-printer-0.7.82.3-1.fc9 has been submitted as an update for Fedora 9
Comment 16 Tim Waugh 2008-05-16 03:52:25 EDT
Works for me.
Comment 17 Fedora Update System 2008-05-17 18:27:11 EDT
system-config-printer-0.7.82.3-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2008-06-06 03:52:47 EDT
system-config-printer-0.7.74.13-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2008-07-26 02:09:46 EDT
system-config-printer-0.7.82.3-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.