Bug 441841 - VM applet will not open Virtual console for domain
VM applet will not open Virtual console for domain
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 10:45 EDT by Alexander Todorov
Modified: 2009-12-14 16:18 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:21:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix virt-manager --show* options. (5.04 KB, text/plain)
2008-09-18 12:21 EDT, Cole Robinson
no flags Details

  None (edit)
Description Alexander Todorov 2008-04-10 10:45:23 EDT
Description of problem:
While domU is running try opening the virtual console using the VM GNOME pannel
applet. It fails.

Version-Release number of selected component (if applicable):
gnome-applet-vm-0.1.2-1.el5

How reproducible:
always

Steps to Reproduce:
1. have a domU running
2. have the VM applet added to some GNOME pannel
3. right click the applet icon
4. a list of running domains (and other options) appears. right click on some of
the running domUs
5. a list of options appears
6. right click on Virtual Console

  
Actual results:
Virtual console is not started for the chosen domain (even after user is asked
to provide root password)

Expected results:
Virtual console is started.

Additional info:
This has been working in previous releases.
Comment 2 RHEL Product and Program Management 2008-04-10 10:53:38 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 4 Karel Zak 2008-09-01 08:20:43 EDT
I don't think this is a regression in the applet. The applet wasn't updated (since RHEL5.0).

It seems like a bug 435264 in virt-manager. I guess we need to backport http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=fdacfd833874 upstream patch to RHEL5. The problem has been fixed in Fedora only...

Alexander, you try to start virt-manager by 

   virt-manager -c Xen --show-domain-console  <domain-UUID>


My test:

# virsh -c test:///default dominfo test
Id:             1
Name:           test
UUID:           004b96e1-2d78-c30f-5aa5-f03c87d21e69
OS Type:        linux
State:          running
CPU(s):         2
CPU time:       1220270608.4s
Max memory:     8388608 kB
Used memory:    2097152 kB

# virt-manager -c test:///default --show-domain-console 004b96e1-2d78-c30f-5aa5-f03c87d21e69
... nothing.

#  virt-manager --show-domain-creator
... nothing
Comment 6 RHEL Product and Program Management 2008-09-03 12:17:23 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 7 Cole Robinson 2008-09-18 12:21:52 EDT
Created attachment 317090 [details]
Fix virt-manager --show* options.

Code is virtually identical to fix upstream. Commands seem to work now.
Comment 8 Jay Turner 2008-09-19 10:44:18 EDT
QE ack for RHEL5.3.
Comment 12 errata-xmlrpc 2009-01-20 16:21:16 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0137.html

Note You need to log in before you can comment on or make changes to this bug.