Bug 441848 - Intel driver gives bogus screen size in mm
Intel driver gives bogus screen size in mm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 11:00 EDT by Peter Bloomfield
Modified: 2008-04-10 16:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 14:33:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Small program to dump screen size. (549 bytes, text/plain)
2008-04-10 11:00 EDT, Peter Bloomfield
no flags Details
xorg.conf (691 bytes, text/plain)
2008-04-10 11:01 EDT, Peter Bloomfield
no flags Details
Xorg.0.log for intel driver (361 bytes, text/plain)
2008-04-10 11:02 EDT, Peter Bloomfield
no flags Details
Xorg.0.log for vesa driver (37.87 KB, text/plain)
2008-04-10 11:03 EDT, Peter Bloomfield
no flags Details
Correct Xorg.0.log for intel driver (22.45 KB, text/plain)
2008-04-10 11:17 EDT, Peter Bloomfield
no flags Details

  None (edit)
Description Peter Bloomfield 2008-04-10 11:00:14 EDT
Description of problem:
When intel is used, my screen (Sony SDM-X82) is reported to be 40959 mm by 6553
mm, whereas vesa gives the correct 361 x 292.  I wouldn't care, except that
Evince believes what it's told (unwisely, imo), and refuses to show a
US-letter-size pdf larger than a small postage stamp--but that's another story.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.2.1-20

How reproducible:
Every time.

Steps to Reproduce:
1.  Attached is a short program that uses {Width,Height}MMOfScreen to display
what the server claims.
2.
3.
  
Actual results:
Screen is 1280 (40959 mm) wide by 1024 (6553 mm) high.

Expected results:
Screen is 1280 (361 mm) wide by 1024 (292 mm) high.

Additional info:
lspci shows:
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated
Graphics Controller (rev 02)
00:02.1 Display controller: Intel Corporation 82945G/GZ Integrated Graphics
Controller (rev 02)

xorg.conf and Xorg.0.log to follow.
Comment 1 Peter Bloomfield 2008-04-10 11:00:14 EDT
Created attachment 302003 [details]
Small program to dump screen size.
Comment 2 Peter Bloomfield 2008-04-10 11:01:33 EDT
Created attachment 302004 [details]
xorg.conf
Comment 3 Peter Bloomfield 2008-04-10 11:02:54 EDT
Created attachment 302007 [details]
Xorg.0.log for intel driver
Comment 4 Peter Bloomfield 2008-04-10 11:03:32 EDT
Created attachment 302008 [details]
Xorg.0.log for vesa driver
Comment 5 Peter Bloomfield 2008-04-10 11:17:57 EDT
Created attachment 302009 [details]
Correct Xorg.0.log for intel driver
Comment 6 Adam Jackson 2008-04-10 14:27:42 EDT
Can you compare the output of 'xdpyinfo | grep dimensions' with 'xrandr | grep
mm' for me?  I think we're just getting out of sync somewhere.
Comment 7 Adam Jackson 2008-04-10 14:33:26 EDT
Actually, not an X bug.  Turns out this was due to gnome-desktop setting the DPI
for you, wildly incorrectly.
Comment 8 Peter Bloomfield 2008-04-10 14:41:28 EDT
OK--just for the sake of completeness:

$ xdpyinfo | grep dimensions
  dimensions:    1280x1024 pixels (40959x6553 millimeters)
$ xrandr | grep mm
VGA connected 1280x1024+0+0 (normal left inverted right x axis y axis) 359mm x 287mm

How can I get gnome-desktop to not mess with the DPI?
Comment 9 Adam Jackson 2008-04-10 16:35:10 EDT
Update to gnome-desktop 2.21.1-2

Note You need to log in before you can comment on or make changes to this bug.