Bug 441862 - wget 1.11 regression: -N disallowed with -O
wget 1.11 regression: -N disallowed with -O
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wget (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 12:00 EDT by Ville Skyttä
Modified: 2008-10-01 02:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 02:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2008-04-10 12:00:30 EDT
wget 1.11 disallows -N with -O (and also "timestamping = on" in wgetrc with -O).
 This breaks scripts that used to work fine without no good reason as far as I
can tell.  One example of such broken script is cdiff from the colordiff
package, to reproduce:

1) Make sure there's a "timestamping = on" in /etc/wgetrc or ~/.wgetrc.
2) Try running "cdiff http://anything"

I think I can work around this in colordiff by patching, but I'd suggest making
use of -N and -O together in wget a warning and not a fatal error in order to
not break backwards compatibility.

Also reported upstream: https://savannah.gnu.org/bugs/index.php?22896
Comment 1 Ville Skyttä 2008-04-10 14:53:32 EDT
A quick grep through my F-8 x86_64 system reveals that at least these tools are
broken with "timestamping = on" in wgetrc and wget 1.11:

/sbin/update-pciids
/usr/bin/abcde
/usr/bin/cddb-tool
/usr/bin/cdiff
/usr/bin/smicache

Upstream agrees that use of timestamping with -O should be a warning, not error.
Comment 2 Karsten Hopp 2008-04-16 05:03:11 EDT
Upstream is aware of this and thinks that this is a misunderstanding in the
meaning of the -O option. Please take a look at the thread starting at
http://article.gmane.org/gmane.comp.web.wget.general/7924

From Micah's mail:
Of course, the whole thing really draws more attention to the fact that
-O is really a pretty confusing option. Most people who read about it
expect it to work like "use this name for the file, instead of a normal
one", when really it works a heluva lot more like shell redirection,
with all its newly-created/truncated-file implications. Given this, it
might have made sense to also add -c to the list of options disallowed
for -N.
Comment 3 Ville Skyttä 2008-04-16 16:58:30 EDT
Hm, NOTABUG, so apps that used to work fine but no longer do due to wget's
(gratuitous IMO) change are the ones that are buggy, not wget?

If so (or even if CANTFIX), then at least the following Fedora packages need to
be checked whether they use "wget -O" and if so, "-e timestamping=off" added to
those commands, or perhaps better changed to use something else like curl instead:

abook
cpanspec
debootstrap
dillo
drupal
gnash-plugin
gpodder
gwget
jigdo
ketchup
p0rn-comfort
rkhunter
rpmdevtools
util-vserver-build
wget
xastir
xfce4-smartbookmark-plugin
xtide-common

I've already patched abcde in Fedora devel, found that rpmdevtools is not
affected, and sent patches to pciutils and libsmi upstreams (no responses so
far).  Would you mind assisting in checking the rest if you think this is not
something that should be fixed in wget?

(Reopening for comments/tracking of progress in checking apps that use wget.)
Comment 4 Behdad Esfahbod 2008-05-05 12:15:57 EDT
I did some mail exchange with Micah too.  I think if we can't fix the case for
timestamping=on in ~/.wgetrc working, this change should be reverted in the
Fedora package at least.

As for the -O confusion, the man page is where that kind of stuff should go.

Cheers,
Comment 5 Micah Cowan 2008-05-13 15:57:46 EDT
Update: Wget 1.11.3 will downgrade this to a warning, and effectively do "-e
timestamping=off" when -O is used (to prevent silly warnings; no other effects
are known).
Comment 6 Micah Cowan 2008-05-13 15:58:24 EDT
(This will be the only change in 1.11.3, aside from updated translations; the
release is expected to take place within the next couple of weeks.)
Comment 7 Ville Skyttä 2008-08-12 15:03:59 EDT
Any ETA when we might see a fixed version in released distro versions?
Comment 8 Ville Skyttä 2008-08-22 14:44:32 EDT
Any updates?  See comment 7.
Comment 9 Karsten Hopp 2008-08-28 05:17:31 EDT
working on it....
Comment 10 Fedora Update System 2008-08-28 09:07:21 EDT
wget-1.11.4-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/wget-1.11.4-1.fc9
Comment 11 Fedora Update System 2008-09-10 02:42:06 EDT
wget-1.11.4-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wget'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7538
Comment 12 Fedora Update System 2008-10-01 02:37:52 EDT
wget-1.11.4-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.