Bug 441879 - Cannot paste into compose window
Cannot paste into compose window
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 13:10 EDT by Orion Poplawski
Modified: 2009-01-12 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 17:10:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-04-10 13:10:57 EDT
Description of problem:

Trying to paste the contents of the X clipboard into a Thunderbird compose
window but nothing happens.  Can copy/paste from elsewhere in the compose
window, but not from any other application.  Running KDE.

Version-Release number of selected component (if applicable):
thunderbird-2.0.0.12-4.fc9.i386
Comment 1 Matěj Cepl 2008-04-10 16:43:50 EDT
Cannot reproduce with the same package of thunderbird on Gnome.
Comment 2 Matěj Cepl 2008-04-10 16:44:50 EDT
Trying to blame KDE. What do you, guys, think about it?
Comment 3 Kevin Kofler 2008-04-10 16:58:26 EDT
What other applications did you try?

Is Klipper running? If so, how is it configured? With the default settings? Or 
have you changed anything?
Comment 4 Orion Poplawski 2008-04-10 17:17:30 EDT
Works konsole and firefox.

Klipper is running - should be stock configuration - I've tried not to do any
configuration.
Comment 5 Kevin Kofler 2008-04-10 17:25:15 EDT
Sorry, I actually meant: from what applications were you trying unsuccessfully 
to paste into Thunderbird?
Comment 6 Orion Poplawski 2008-04-10 17:38:40 EDT
I can paste from Firefox and OO Writer.  I can't paste from konsole and konqueror.
Comment 7 Rex Dieter 2008-04-10 17:45:11 EDT
If I recall, I do that exact operation (copy from konsole/konq, paste into
thunderbird) almost every day.

I'll go (re)check, to make sure I'm not just going senile.
Comment 8 Lukáš Tinkl 2008-04-11 04:01:29 EDT
Could be that klipper is causing that behavior, try to disable it
Comment 9 Orion Poplawski 2008-04-11 12:54:12 EDT
Quit klipper and disabled running in on login.  Logged out and back it.  Still
can't paste.
Comment 10 Rex Dieter 2008-04-11 13:19:02 EDT
Copy konsole/konq contents, paste into Thunderbird, worksforme, *with* klipper.

wierd.
Comment 11 Orion Poplawski 2008-04-11 15:24:11 EDT
I can't reproduce it on a different laptop, so it may be hardware dependent.
Comment 12 Orion Poplawski 2008-04-11 15:26:17 EDT
Okay, found the difference/issue.  It doesn't work with HTML compose.  If you
are in text compose or if you do "Paste without formatting" it works.  So, who's
fault is it - KDE or Thunderbird?  How do we know more about the "format" of the
selection?
Comment 13 Rex Dieter 2008-04-11 17:44:54 EDT
back to TB and see.
Comment 14 Bug Zapper 2008-05-14 05:15:35 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Steven M. Parrish 2009-01-10 14:10:34 EST
Is this still an ongoing issue or has it been resolved?
Comment 16 Orion Poplawski 2009-01-12 17:10:22 EST
This appears to be fixed in F10 with TB 2.0.0.19.

Note You need to log in before you can comment on or make changes to this bug.