Bug 441890 - NS_ERROR_FAILURE in nsIJSON.decode/PU_unwrapNodes
NS_ERROR_FAILURE in nsIJSON.decode/PU_unwrapNodes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 13:28 EDT by Axel Thimm
Modified: 2008-07-25 13:34 EDT (History)
0 users

See Also:
Fixed In Version: firefox-3.0.1-1.fc9.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 13:34:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2008-04-10 13:28:43 EDT
Description of problem:
Firing up firefox returns

*** unwrapNodes(): JSON.decode(): [Exception... "Component returned failure
code: 0x80004005 (NS_ERROR_FAILURE) [nsIJSON.decode]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
file:///usr/lib64/xulrunner-1.9pre/modules/utils.js :: PU_unwrapNodes :: line
529"  data: no]


Version-Release number of selected component (if applicable):
xulrunner-1.9-0.53.beta5.fc9.x86_64
xulrunner-1.9-0.53.beta5.fc9.i386
firefox-3.0-0.53.beta5.fc9.x86_64


How reproducible:
always

Steps to Reproduce:
1.Run firefox in a console to see the output
2.
3.
  
Actual results:
see above

Expected results:
no errors/warning

Additional info:
I'm chasing a bug with firefox crashing when mugshot tried to open a page, I'm
not sure this is related to that crash, I'll file a new report for the crash.
Comment 1 Matěj Cepl 2008-04-11 07:46:11 EDT
I cannot reproduce this on the very same packages.
Comment 2 Axel Thimm 2008-04-11 12:12:30 EDT
(In reply to comment #1)
> I cannot reproduce this on the very same packages.

I just named the packages that I suspect being involved, the bug doesn't need to
be in one of them. This is just an up2date rawhide/x86_64 with a medium set of
packages.

FWIW the crashing mugshot issue is a different one, after disabling the mugshot
extension the above warning/error still remains.
Comment 3 Bug Zapper 2008-05-14 05:15:50 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Matěj Cepl 2008-07-25 11:05:10 EDT
Axel, can you still reproduce it with the latest updates to Fedora 9? Sorry, for
letting this bug rottening here for so long. If yes, could we get output of

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Axel Thimm 2008-07-25 13:34:24 EDT
I don't see that error any more, but I removed the mugshot extension (although I
don't know whether that was causing the error or not).

Note You need to log in before you can comment on or make changes to this bug.