Bug 441922 - anaconda needs to be rebuilt with latest libnl
Summary: anaconda needs to be rebuilt with latest libnl
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 5.2
Hardware: ia64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks: 434826
TreeView+ depends on / blocked
 
Reported: 2008-04-10 18:39 UTC by Doug Chapman
Modified: 2008-05-21 15:33 UTC (History)
2 users (show)

Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 15:33:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0397 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2008-05-19 23:11:23 UTC

Description Doug Chapman 2008-04-10 18:39:34 UTC
Description of problem:
In order to completely resolve BZ 434826 anaconda needs a rebuild.  We still see
the errors in stage1 since it is static linked.  The stage2 issues have cleared
up since that is dynamic linked.



Version-Release number of selected component (if applicable):
anaconda-11.1.2.112-1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Doug Chapman 2008-04-10 19:00:19 UTC
Just for sanity sake I confirmed that anaconda was indeed built with the
previous version:

from: http://brewweb.devel.redhat.com/brew/getfile?taskID=1253934&name=root.log

 libnl                   ia64       1.0-0.10.pre5.4  core              118 k
 libnl-devel             ia64       1.0-0.10.pre5.4  core              178 k

the version of libnl with the unaligned access fix is: libnl-devel-1.0-0.10.pre5.5



Comment 3 David Cantrell 2008-04-10 20:38:21 UTC
We can specifically require the >= version of libnl in anaconda.spec and rebuild for 5.2.  Reassigning to 
clumens.

Comment 7 Chris Lumens 2008-04-16 09:25:16 UTC
This will be fixed in anaconda-11.1.2.113-1.

Comment 9 Doug Chapman 2008-04-17 17:06:24 UTC
I verified that all is now well with the latest nightly tree which includes
anaconda-11.1.2.113-1.

thanks!

- Doug


Comment 11 errata-xmlrpc 2008-05-21 15:33:50 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html



Note You need to log in before you can comment on or make changes to this bug.