Bug 441948 - Please correct swapon -s to global commuity user base.
Please correct swapon -s to global commuity user base.
Status: CLOSED DUPLICATE of bug 70477
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-10 16:13 EDT by Darwin H. Webb
Modified: 2008-05-07 06:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-07 06:24:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Darwin H. Webb 2008-04-10 16:13:55 EDT
Description of problem:
A long standing problem with the usage of swap partitions during and after
install for multiple booting.
This issue triggers many debates on very fine and sketchy details not understood
by the average user. The subject is only seen by the user's point of view rather
than making the install operate correctly so a psychology choice can be made by
each type of install.

The use of swapon -s should be replaced with swapon /dev/<devnanepath> for the
swap created during install. The swap should always be re-created (with mkswap).
The /swap mount point should be for the primary swap in the exiting fstab (with
an option box to "Don't re-use other swaps" in fstab (in the case where the new
install is not related to the existing install.)

Now a newbie will get one swap, a dual booting hobbyist can have one swap for
all his junk, but a true multi use system can have 1 to 16 swaps, reuse the
primary (the others or notor not) during re-install. 

This puts the choice on the non best practice users while insuring the subtle
less know reasons for having separate swaps for each system (like encryption,
sensitive data, hibernation, large vs. small pages) are automagically respected.

This change would make the whole world a better place and spread peace through
out the lands. 

thank you,


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Darwin H. Webb 2008-05-05 21:52:48 EDT
I said swapon -s but that is probably not what it being used.
More like -a -e ?
I also noticed that swap is not in fstab in the early F9.
Haven checked lately.

Comment 2 Joel Andres Granados 2008-05-07 06:24:06 EDT
we use the swapon() with the path in the installer.
We use the mkswap to re-create swap as well.

the third problem is a known one.  the fact that sometimes the user has a lot of
swaps that the insaller should not touch (during installation and post
installation).  We are working a way to ignore the swap devices.  I'm going to
dupe this bug to reflect that it has the same concerns as the "installer
touching my swap device" one.
Comment 3 Joel Andres Granados 2008-05-07 06:24:32 EDT

*** This bug has been marked as a duplicate of 70477 ***

Note You need to log in before you can comment on or make changes to this bug.