Bug 441968 - Livecd-creator hangs during installation process
Livecd-creator hangs during installation process
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 17:42 EDT by Brian Clark
Modified: 2008-04-14 13:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 13:42:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sealerts after 3rd attempt (6.65 KB, application/octet-stream)
2008-04-11 09:50 EDT, Brian Clark
no flags Details

  None (edit)
Description Brian Clark 2008-04-10 17:42:43 EDT
Description of problem:  Building live-cd on rawhide stops on glibc-common


Version-Release number of selected component (if applicable): 015-1.fc9


How reproducible: done it twice


Steps to Reproduce:
1. execute livecd-creator --config=livecd-fedora-tech.ks (this file is
/usr/share/livecd-fedora-minimal plus clamav packages)
2.
3.
  
Actual results:
Process hangs at install glibc-common, eventually desktop resets.

Expected results: bootable live cd


Additional info:
[root@localhost /]# sealert -l fa8fcbee-2ac0-4d92-b265-6b8e50ef625e

Summary:

SELinux is preventing livecd-creator (tzdata_t) "sigchld" to <Unknown>
(unconfined_notrans_t).

Detailed Description:

SELinux denied access requested by livecd-creator. It is not expected that this
access is required by livecd-creator and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                unconfined_u:unconfined_r:tzdata_t:s0-s0:c0.c1023
Target Context                unconfined_u:unconfined_r:unconfined_notrans_t:s0-
                              s0:c0.c1023
Target Objects                None [ process ]
Source                        livecd-creator
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           python-2.5.1-25.fc9
Target RPM Packages           
Policy RPM                    selinux-policy-3.3.1-31.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain
                              2.6.25-0.204.rc8.git4.fc9.x86_64 #1 SMP Mon Apr 7
                              10:25:52 EDT 2008 x86_64 x86_64
Alert Count                   2
First Seen                    Thu Apr 10 15:59:34 2008
Last Seen                     Thu Apr 10 16:45:05 2008
Local ID                      fa8fcbee-2ac0-4d92-b265-6b8e50ef625e
Line Numbers                  

Raw Audit Messages            

host=localhost.localdomain type=AVC msg=audit(1207860305.221:47): avc:  denied 
{ sigchld } for  pid=4824 comm="livecd-creator"
scontext=unconfined_u:unconfined_r:tzdata_t:s0-s0:c0.c1023
tcontext=unconfined_u:unconfined_r:unconfined_notrans_t:s0-s0:c0.c1023
tclass=process

host=localhost.localdomain type=SYSCALL msg=audit(1207860305.221:47):
arch=c000003e syscall=61 success=no exit=-10 a0=0 a1=7fff875d586c a2=1 a3=0
items=0 ppid=4384 pid=4824 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0
sgid=0 fsgid=0 tty=pts1 ses=3 comm="livecd-creator" exe="/usr/bin/python"
subj=unconfined_u:unconfined_r:unconfined_notrans_t:s0-s0:c0.c1023 key=(null)
Comment 1 Brian Clark 2008-04-11 09:50:32 EDT
Created attachment 302117 [details]
sealerts after 3rd attempt

more information on the sealerts
Comment 2 Daniel Walsh 2008-04-14 13:42:13 EDT
I fixed this AVC, but we should probably do something about livecd-creator,
failing to run in enforcing mode, since it will only screw up your machine. 
livecd's need to be created in permissive mode.  Since they will install an
selinux-policy that will be different then the host and can send the machine in
to a death spiral.

Fixed in selinux-policy-3.3.1-35.fc9

Note You need to log in before you can comment on or make changes to this bug.