Bug 44197 - missing sound on UP1100
Summary: missing sound on UP1100
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-12 01:04 UTC by Michal Jaegermann
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-15 02:05:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch for missing sound on Nautilus machines (1.27 KB, patch)
2001-06-15 02:05 UTC, Michal Jaegermann
no flags Details | Diff

Description Michal Jaegermann 2001-06-12 01:04:25 UTC
Description of Problem:
With Alpha UP1100 and its built-in sound card I am getting
with 2.2.19aa2 the following:

Trident 4DWave/SiS 7018/Ali 5451 PCI Audio, version 0.14.6a, 19:28:59 Apr
30 2001
trident: ALi Audio Accelerator found at IO 0x10000, IRQ 10
ac97_codec: AC97  codec, vendor id1: 0x0000, id2: 0x0000 (Unknown)
ac97_codec: Secondary ac97 codec not present
trident: Running on Alpha system type Nautilus

and I can play various sounds and CDs.

With a kernel 2.4.3-7 from RC1 I see this:

Trident 4DWave/SiS 7018/ALi 5451 PCI Audio, version 0.14.6, 16:08:06 May 21
2001
trident: ALi Audio Accelerator found at IO 0x8000, IRQ 10
ac97_codec: AC97  codec, id: 0x0000:0x0000 (Unknown)
ac97_codec: Secondary ac97 codec not present

and there is not a single peep.


How Reproducible:
Seems to be a property of all 2.4 kernels I tried so far.  Sigh!

  Michal
  michal@harddata.com

Comment 1 Michal Jaegermann 2001-06-15 02:03:55 UTC
The problem is that a "generic" Alpha kernel on Nautilus does not have
a proper initialization code for a Nautilus sound card.  A copy of this
code from 2.2.19 kernel solves the problem. Header comments clearly
show that DRIVER_VERSION define was forgotten in updates.

This patch is done with 2.4.5-ac13 kernel but it will fit trident.c in
all 2.4.x, so far, kernels possibly with some offsets.  The patch will
be submitted on linux-kernel list and is attached. My patched kernel
plays now very loudly. :-)


Comment 2 Michal Jaegermann 2001-06-15 02:05:23 UTC
Created attachment 21142 [details]
A patch for missing sound on Nautilus machines

Comment 3 Phil Copeland 2001-06-15 12:16:54 UTC
Added for inclusion in a future erratta kernel
(not current one thats being QA'd though this was 2 days ltoo late for that,
sorry)


Note You need to log in before you can comment on or make changes to this bug.