Bug 441973 - Firefox ignores $LC_MESSAGES
Firefox ignores $LC_MESSAGES
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 18:20 EDT by Lennart Poettering
Modified: 2009-09-21 16:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 06:06:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2008-04-10 18:20:57 EDT
Firefox ignores the setting of $LC_MESSAGES=C and shows the UI in german, just
because I set $LANG to german.

Firefox should honour $LC_MESSAGES properly, just like any other good program.
Comment 1 Robert Marcano 2008-04-10 19:24:47 EDT
looks like the problem is the Fedora script used to launch firefox, it does
check that the language extension is installed using the LANG. That script is RH
specific, I removed the offending line and let firefox select the language by
itself,

With LANG=ja_JP I saw the UI in Japanese., with both LC_MESSAGES=en_US
LANG=ja_JP everything was shown on English.

Related lines on /usr/bin/firefox:

# Try without a local variant first, then with a local variant
# So that pt-BR doesn't try to use pt for example
SHORTMOZLOCALE=`echo $LANG | sed "s|_\([^.]*\).*||g"`
[ -f
$MOZ_EXTENSIONS_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org/chrome/$SHORTMOZLOCALE.jar
] && MOZARGS="-UILocale $SHORTMOZLOCALE"

MOZLOCALE=`echo $LANG | sed "s|_\([^.]*\).*|-\1|g"`
[ -f
$MOZ_EXTENSIONS_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org/chrome/$MOZLOCALE.jar
] && MOZARGS="-UILocale $MOZLOCALE"
Comment 2 Matěj Cepl 2008-04-11 07:49:47 EDT
Perfectly reproducable.
Comment 3 Bug Zapper 2008-05-14 05:17:03 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Martin Stransky 2008-10-24 08:58:53 EDT
Taking this one...
Comment 5 Jan Horak 2009-01-29 06:06:40 EST
Commit to CVS and fixed in next release.

Note You need to log in before you can comment on or make changes to this bug.