Bug 441998 - virt-install does not display translated help
virt-install does not display translated help
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 01:40 EDT by Jens Petersen
Modified: 2008-12-21 03:23 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 07:58:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-04-11 01:40:01 EDT
Description of problem:
virt-install does not seem to work in rawhide.

How reproducible:
every time

Steps to Reproduce:
1. LANG=ja_JP.UTF-8 virt-install --help
2. virt-install --location
http://some.fedora.mirror/pub/fedora/linux/development/i386/os/
  
Actual results:
1. python backtrace says:
ERROR:root:'ascii' codec can't decode byte 0xe3 in position 120: ordinal not in
range(128)
Traceback (most recent call last):
  File "/usr/bin/virt-install", line 497, in <module>
    main()
  File "/usr/bin/virt-install", line 341, in main
    options = parse_args()
  File "/usr/bin/virt-install", line 281, in parse_args
    (options,args) = parser.parse_args()
  File "/usr/lib/python2.5/optparse.py", line 1378, in parse_args
    stop = self._process_args(largs, rargs, values)
  File "/usr/lib/python2.5/optparse.py", line 1418, in _process_args
    self._process_long_opt(rargs, values)
  File "/usr/lib/python2.5/optparse.py", line 1493, in _process_long_opt
    option.process(opt, value, values, self)
  File "/usr/lib/python2.5/optparse.py", line 782, in process
    self.action, self.dest, opt, value, values, parser)
  File "/usr/lib/python2.5/optparse.py", line 804, in take_action
    parser.print_help()
  File "/usr/lib/python2.5/optparse.py", line 1648, in print_help
    file.write(self.format_help().encode(encoding, "replace"))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe3 in position 120:
ordinal not in range(128)

Expected results:
no backtrace
Comment 1 Jens Petersen 2008-04-11 01:41:24 EDT
(2. was a different bug seems to be assuming xen?)

Comment 2 Bug Zapper 2008-05-14 05:18:08 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Cole Robinson 2008-06-12 15:34:46 EDT
A fix for this has been committed upstream:

http://hg.et.redhat.com/virt/applications/virtinst--devel?cs=94d1a32b1811
Comment 4 Fedora Update System 2008-12-01 11:30:15 EST
python-virtinst-0.400.0-0.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/python-virtinst-0.400.0-0.fc9
Comment 5 Fedora Update System 2008-12-01 13:21:09 EST
python-virtinst-0.400.0-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/python-virtinst-0.400.0-1.fc9
Comment 6 Jens Petersen 2008-12-01 21:19:08 EST
Still happens for me with python-virtinst-0.400.0-4.fc10.
Comment 7 Cole Robinson 2008-12-01 23:10:00 EST
Argh, I forgot to build the updated f10 package. This will be fixed in python-virtinst-0.400.0-5.fc10.

But this bug is against F9, and this should be fixed in python-virtinst-0.400.0-1.fc9. So please try with that version. Moving back to POST.
Comment 8 Cole Robinson 2008-12-01 23:14:18 EST
Whoops, okay, you moved it to F10. :)

Moving to assigned, I'll address this with an updated package tomorrow.
Comment 9 Fedora Update System 2008-12-02 11:01:00 EST
python-virtinst-0.400.0-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/python-virtinst-0.400.0-5.fc10
Comment 10 Fedora Update System 2008-12-02 20:14:51 EST
python-virtinst-0.400.0-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update python-virtinst'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-10541
Comment 11 Fedora Update System 2008-12-06 23:20:46 EST
python-virtinst-0.400.0-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10810
Comment 12 Fedora Update System 2008-12-08 07:58:49 EST
python-virtinst-0.400.0-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-12-21 03:23:40 EST
python-virtinst-0.400.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.