Bug 44200 - formail 3.14 corrupts lines that look like headers
formail 3.14 corrupts lines that look like headers
Status: CLOSED DUPLICATE of bug 44198
Product: Red Hat Linux
Classification: Retired
Component: procmail (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
http://bugzilla.redhat.com/bugzilla/s...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-11 22:04 EDT by peterw
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-11 22:04:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description peterw 2001-06-11 22:04:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.19-6.2.1 i686; en-US; rv:0.9.1)
Gecko/20010607

Description of problem:
The formail binary from procmail 3.14-6 tries to "clean up" message headers
that contain whitespace between the header name and the colon, e.g.
"Subject : test" becomes "Subject: test". But it does this for all lines,
even within the body of a message. It should only do this sort of thing to
message headers.

Data corruption of course is rather evil. PGP-signed messages may be
rendered unverifiable. Source code or other important data sent via email
may be rendered unusable or even dangerous.



How reproducible:
Always

Steps to Reproduce:
1. printf 'Subject: test\nTo: test\nFrom: test\n\nhere is text\nNotaheader
: this is a body line\n' | formail -f

(Note: that is one line, with a space between "Notaheader" and ":"

	

Actual Results:  "Notaheader : this is a body line" is changed to
"Notaheader: this is a body line" (the space between "Notaheader" and the
colon is removed).



Expected Results:  formail should echo exactly what printf gave it, as the
Subject/To/From headers are correct, and the "Notaheader" line is in the
message body.



Additional info:

The HISTORY file at www.procmail.org suggests that this problem was
introduced in procmail 3.14 and fixed in procmail 3.15. I have tested the
formail binary from the official procmail 3.15.1 distribution, and it does
seem to handle these messages properly.

As suggested by the URL, this seems to be the same bug as I found in Red
Hat 6.2. (It doesn't seem possible to enter a bug for more than one version
of Red hat Linux at the same time.) Attempting to assign to the same person
who was assigned bug #44198 (though I'm sure this will be marked as a
duplicate of #44198, or vice-versa).

Thanks.
Comment 1 Trond Eivind Glomsrxd 2001-06-12 10:18:07 EDT

*** This bug has been marked as a duplicate of 44198 ***

Note You need to log in before you can comment on or make changes to this bug.