Bug 442004 - file conflicts - with deleted file - solved with yum clean all
file conflicts - with deleted file - solved with yum clean all
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 03:09 EDT by Bob Gustafson
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 17:05:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2008-04-11 03:09:17 EDT
Description of problem:

I was trying to get synced up with Fedora openoffice after having installed the
openoffice.org version. I deleted lots of files and rebooted a couple of times
and finally came down to errors of the form:

Transaction Check Error:
  file
/usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.oasis.opendocument.database.png
from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from
package openoffice.org-redhat-menus-2.3-9238.noarch

The odd thing about these errors is that I really did delete the file 

/usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.oasis.opendocument.database.png


It was just not in the directory when I did 'ls'.

The yum file conflicts persisted even after a reboot.

The solution was to go into yum and do

  yum clean all

Version-Release number of selected component (if applicable):

  yum-3.2.8-2.fc8

How reproducible:

 Before doing the yum clean all, the error was frustratingly persistent.

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Seth Vidal 2008-04-14 17:05:54 EDT
okay so you have separate items here:
1. removing the file doesn't remove it from the rpmdb's record of the file - so
that's why removing the file didn't help the problem
2. when you did the clean all you talked to a different mirror and/or reset your
metadata which probably had a fixed (and updated) openoffice which implicitly
fixed the problem you were having.

I'm going to close this not a bug b/c the error message it outputted for you was
entirely valid.

thanks

Note You need to log in before you can comment on or make changes to this bug.