Bug 442015 - yum-updatesd & puplet doesn't work well with NetworkManager
yum-updatesd & puplet doesn't work well with NetworkManager
Status: CLOSED DUPLICATE of bug 480339
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-updatesd (Show other bugs)
i686 Linux
low Severity medium
: rc
: ---
Assigned To: James Antill
Depends On:
  Show dependency treegraph
Reported: 2008-04-11 05:37 EDT by Ruben Haugan
Modified: 2012-04-24 03:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-04-24 03:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ruben Haugan 2008-04-11 05:37:18 EDT
Description of problem:
I work on my laptop all the time, and use NetworkManager to manage my network 
connections, almost always wireless connections. When booting the computer, yum-
updatesd is started before Networkmanager and NetworkManagerDispatcher, and 
thus cannot initially connect to the net and check for updates. Therefore, when 
logging in to GNOME, puplet connects to yum-updatesd which doesnt report any 
available updates.

This would have been fine as long as available updates where reported to puplet 
as available when yum-updatesd checks for updates again (as per settings 
in /etc/yum/yum-updatesd.conf), but this never happens. I _never_ recieve 
notifications, and the puplet icon is _never_ visible.

It seems to me, that yum-updatesd fails to emit dbus-messages permanently to 
puplet if it fails to connect to the network when the daemon starts.

Version-Release number of selected component (if applicable):

How reproducible: Every time

Steps to Reproduce:
1. Boot the computer
2. Log in to GNOME
3. Wait indefinately
Actual results:
No notifications are presented

Expected results:
Notifications emitted from yum-updatesd to puplet, and icon in notification 

Additional info:
I am able to bypass the problem and recieve notifications as expected by doing 
the following:

1. Disable yum-updatesd from starting automatically at boot
2. Create script /usr/bin/yum-updatesd_delay and call it from /etc/rc.local:

sleep 180
/etc/init.d/yum-updatesd start

3. Create script /usr/bin/puplet_delay and call it (instead of the usual puplet 
command) automatically when logging in to GNOME:

sleep 240
/usr/bin/puplet &

This gives me a 3 minute window to log in to GNOME and get a network connection 
running before yum-updatesd starts, and furthermore gives yum-updatesd in 
excess of 1 minute to resolve updates so that puplet, when it starts, can 
recieve a meaningfull message over dbus and present notifications. (Puplet 
seems to fail (and doesn't recover again) if it starts before yum-updatesd is 

This actually works for me 95% of the time, but it just doesn't cut it for an 
Enterprise OS.
Comment 1 Karel Srot 2012-03-28 12:25:19 EDT
Just setting flags.
Comment 2 RHEL Product and Program Management 2012-04-02 06:36:23 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Karel Srot 2012-04-19 05:11:45 EDT
I have set the flags for 5.9 so this bug won't be lost but I don't think it is an issue right now, the bug is several years without update. 
I incline to close it.
Comment 6 Karel Srot 2012-04-24 03:37:55 EDT
Just found that this is duplicate to bug 480339.

*** This bug has been marked as a duplicate of bug 480339 ***

Note You need to log in before you can comment on or make changes to this bug.