Bug 442019 - yum blocks when having blocking file systems
yum blocks when having blocking file systems
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rpm (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Panu Matilainen
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 06:35 EDT by Klaus Ethgen
Modified: 2010-11-15 05:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 05:43:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaus Ethgen 2008-04-11 06:35:23 EDT
Description of problem:
We have systems where a file system (NFS) is unaccessible sometimes. Also there 
are file systems wher root has no access and will not have ever.

In the later case we get just a "Permission denied" which is not nice but ok. 
In the first case yum will block forever.

How reproducible:
- Mount a NFS filesystem from a remote server
- Switch off the remote server (or make it unavailable per iptables or other)
- Try to install/remove packages with yum
  
Actual results:
It blocks

Expected results:
No block
Comment 1 James Antill 2009-03-25 01:39:26 EDT
What could it do? What other programs don't fail in this way?
Comment 2 Klaus Ethgen 2009-03-25 03:20:39 EDT
Ehem, That it clearly a bug.

There is no reason why yum should block when the filesystem is not releated to the path where to install.

Ok, I did forget to mention that I mean to have the NFS filesystem in (for example) /home/.../... or /net/... or somethink absolutelly unrelated to any path yum is needed to access.

To your question: I d not know any other program which fails this way.

So this IS a bug. And a grave one too.
Comment 3 James Antill 2009-03-25 09:12:09 EDT
 So you have a path like:

/my/inaccessible/path

...and yum has problems with it? This only when installing/removing packages, yes?
 Does rpm work? As I seem to recall that rpm stats. mount points when it runs the transaction. So moving there, but it's NaB IMO or maybe a feature request.
Comment 5 Panu Matilainen 2010-11-15 05:43:58 EST
Rpm in RHEL 6 only accesses and stat()'s paths actually relevant to the transaction, so it doesn't hang on unrelated things like NFS mounts. It's not backportable to RHEL 5 however due to the API changes involved.

Note You need to log in before you can comment on or make changes to this bug.