Bug 442021 - Wrong Requires leads to broken deps in rawhide
Wrong Requires leads to broken deps in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: postgresql-pgpool-II (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Devrim GUNDUZ
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Upgrade
  Show dependency treegraph
 
Reported: 2008-04-11 06:40 EDT by Alex Lancaster
Modified: 2008-04-11 23:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 15:01:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix .spec file (1.09 KB, patch)
2008-04-11 06:42 EDT, Alex Lancaster
no flags Details | Diff

  None (edit)
Description Alex Lancaster 2008-04-11 06:40:55 EDT
This has been broken for a couple of days now:

Broken deps for i386
----------------------------------------------------------
        postgresql-pgpool-II-devel-2.1-beta2.fc9.1.i386 requires
postgresql-pgpool-II = 0:2.1-beta2

The cause is incorrect usage of Requires, which should include the full version
including release:

Requires:       %{name} = %{version}-%{release}

in addition, the release tag does not conform to the package numbering scheme,
as per:

http://fedoraproject.org/wiki/Packaging/NamingGuidelines#head-d97a3f40b6dd9d2288206ac9bd8f1bf9b791b22a

it should be of the form:

0.%{X}.%{alphatag}%{?dist}

hence in this case:  0.2.beta2%{?dist}

If you opened up your ACLs on pkgdb (check "group members can commit?"):

https://admin.fedoraproject.org/pkgdb/packages/name/postgresql-pgpool-II

then I (or others could fix it directly).
Comment 1 Alex Lancaster 2008-04-11 06:42:36 EDT
Created attachment 302100 [details]
Patch to fix .spec file
Comment 2 Devrim GUNDUZ 2008-04-11 15:01:22 EDT
Thanks for the patch. Package updated.
Comment 3 Alex Lancaster 2008-04-11 23:58:00 EDT
(In reply to comment #2)
> Thanks for the patch. Package updated.

Thanks, did you mail rel-eng to ask that the build: 

http://koji.fedoraproject.org/koji/buildinfo?buildID=45945

be tagged f9-final?

Also, could you open up the ACLs for the package via PackageDB (or otherwise
explain why you think it should remain closed)?

Note You need to log in before you can comment on or make changes to this bug.