Bug 442034 - yum grouplist shows misleading information
yum grouplist shows misleading information
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 08:50 EDT by Scott Glaser
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 08:17:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing games available in yumex even though yum says they are not available. (209.27 KB, image/png)
2008-04-11 08:50 EDT, Scott Glaser
no flags Details

  None (edit)
Description Scott Glaser 2008-04-11 08:50:10 EDT
Description of problem:

The command yum grouplist shows misleading information. It shows several groups
that are installed and available for installation which leads to confusion with
new users. Some examples are Games and Entertainment and KDE (K Desktop
Environment). With Games and Entertainment it shows available and installed, yet
when the command yum groupinstall 'Games and Entertainment' is issue it returns
"No packages in any requested group available to install or update", yet with
yumex it shows several games that are not installed.

Version-Release number of selected component (if applicable):

rpm-4.4.2.2-7.fc8
deltarpm-3.4-6.fc8
rpm-python-4.4.2.2-7.fc8
rpm-libs-4.4.2.2-7.fc8

yum-metadata-parser-1.1.2-1.fc8
yum-updatesd-0.9-1.fc8
yum-skip-broken-1.1.11-1.fc8
yum-fastestmirror-1.1.11-1.fc8
yum-versionlock-1.1.11-1.fc8
yumex-2.0.4-1.fc8
yum-3.2.8-2.fc8
yum-updateonboot-1.1.11-1.fc8
yum-basearchonly-1.1.11-1.fc8
yum-utils-1.1.11-1.fc8
yum-arch-2.2.2-2.fc7

How reproducible:

Every time the command is run it returns "No packages in any requested group
available to install or update"

Steps to Reproduce:

1. Ensure that the Games and Entertainment group is not installed.
2. Execute the command "yum groupinstall 'Games and Entertainment'"
  
Actual results:

yum grouplist
Loading "basearchonly" plugin
Loading "fastestmirror" plugin
Loading "skip-broken" plugin
Setting up Group Process
Loading mirror speeds from cached hostfile
 * livna: ftp-stud.fht-esslingen.de
 * fedora: fedora.ifc.unam.mx
 * adobe-linux-i386: linuxdownload.adobe.com
 * updates: fedora.ifc.unam.mx
Installed Groups:
   Office/Productivity
   Editors
   System Tools
   Base
   Fonts
   Text-based Internet
   GNOME Desktop Environment
   Base
   Authoring and Publishing
   Hardware Support
   Games and Entertainment
   Legacy Software Development
   Network Servers
   X Window System
   Graphics
   Web Server
   KDE (K Desktop Environment)
   Miscellaneous command line tools
   Printing Support
   Hardware Support
   Mail Server
   Server Configuration Tools
   Administration Tools
   Legacy Fonts
   Sound and Video
   Sound and Video
   Graphical Internet
Available Groups:
   Games and Entertainment
   Engineering and Scientific
   MySQL Database
   Development Libraries
   Window Managers
   Fedora Packager
   Development Tools
   GNOME Software Development
   News Server
   XFCE Software Development
   X Software Development
   Virtualization
   Legacy Network Server
   DNS Name Server
   FTP Server
   Java Development
   XFCE
   Clustering
   Games and Entertainment
   Hardware Support
   Web Development
   Windows File Server
   Fedora Eclipse
   KDE Software Development
   KDE (K Desktop Environment)
   Educational Software
   PostgreSQL Database
   GNOME Desktop Environment
   Internet
   System Tools
Done

yum groupinstall 'Games and Entertainment'
Loading "basearchonly" plugin
Loading "fastestmirror" plugin
Loading "skip-broken" plugin
Loading mirror speeds from cached hostfile
 * livna: ftp-stud.fht-esslingen.de
 * fedora: mirror.cpsc.ucalgary.ca
 * adobe-linux-i386: linuxdownload.adobe.com
 * updates: fedora.ifc.unam.mx
Setting up Group Process
Loading mirror speeds from cached hostfile
 * livna: ftp-stud.fht-esslingen.de
 * fedora: mirror.cpsc.ucalgary.ca
 * adobe-linux-i386: linuxdownload.adobe.com
 * updates: fedora.ifc.unam.mx
No packages in any requested group available to install or update


Expected results:

Expect the Games and Entertainment group of packages to be installed.

Additional info:
Comment 1 Scott Glaser 2008-04-11 08:50:10 EDT
Created attachment 302114 [details]
Screenshot showing games available in yumex even though yum says they are not available.
Comment 2 Seth Vidal 2008-04-14 16:41:38 EDT
by default a groupinstall will only install the default or mandatory pkgs in a
group.

If you run:
yum groupinfo "Games and Entertainment" do the pkgs that yumex is listing fall
into the 'optional' section?
Comment 3 Scott Glaser 2008-04-14 20:13:59 EDT
No the games listed by yum groupinfo "Games and Entertainment" were:

Group: Games and Entertainment
 Description: Various ways to relax and spend your free time.
 Optional Packages:
   crimson-fields
   xrick


Yet those 2 games are not listed in yumex.  There are many, many more games
listed in yumex when checked, however the 2 listed above are not listed in yumex.

Here is the list of games from yumex with only the fedora repository enabled:

FlightGear.i386 = FlightGear,i386,0,0.9.11,0.4.pre1.fc8,fedora
zasx.i386 = zasx,i386,0,1.30,5.fc8,fedora
KoboDeluxe.i386 = KoboDeluxe,i386,0,0.4,0.4.pre10.fc8,fedora
Maelstrom.i386 = Maelstrom,i386,0,3.0.6,14,fedora
Ri-li.i386 = Ri-li,i386,0,2.0.0,2.fc8,fedora
TnL.i386 = TnL,i386,0,070909,2.fc8,fedora
abe.i386 = abe,i386,0,1.1,6.fc8,fedora
abuse.i386 = abuse,i386,0,0.7.0,5.fc8,fedora
agistudio.i386 = agistudio,i386,0,1.2.3,4.fc8,fedora
alex4.i386 = alex4,i386,0,1.0,4.fc8,fedora
alienblaster.i386 = alienblaster,i386,0,1.1.0,3.fc8,fedora
alphabet-soup.i386 = alphabet-soup,i386,0,1.1,3.fc8,fedora
ants.i386 = ants,i386,0,1.4,3.fc8,fedora
armacycles-ad.i386 = armacycles-ad,i386,0,0.2.8.2.1,5.fc8,fedora
arrows.i386 = arrows,i386,0,0.6,5.fc8,fedora
asc.i386 = asc,i386,0,1.16.4.0,3.fc8,fedora
asc-music.noarch = asc-music,noarch,0,1.0,2.fc8,fedora
astromenace.i386 = astromenace,i386,0,1.2,3.fc8,fedora
atomix.i386 = atomix,i386,0,2.14.0,3.1,fedora
atomorun.i386 = atomorun,i386,0,1.1,0.5.pre2.fc8,fedora
auriferous.i386 = auriferous,i386,0,1.0.1,4.fc8,fedora
ballbuster.i386 = ballbuster,i386,0,1.0,3.fc8,fedora
ballz.i386 = ballz,i386,0,1.0,1.fc8,fedora
beneath-a-steel-sky-cd.noarch = beneath-a-steel-sky-cd,noarch,0,0.0372,2.fc8,fedora
beneath-a-steel-sky.noarch = beneath-a-steel-sky,noarch,0,0.0348,4.fc8,fedora
berusky.i386 = berusky,i386,0,1.1,6.fc8,fedora
blobAndConquer.i386 = blobAndConquer,i386,0,0.91,4.fc8,fedora
blobby.i386 = blobby,i386,0,0.6,0.7.a.fc8,fedora
blobwars.i386 = blobwars,i386,0,1.07,1.fc8,fedora
bombardier.i386 = bombardier,i386,0,0.8.2.2,7.fc8,fedora
boswars.i386 = boswars,i386,0,2.4.1,3.fc8,fedora
bsd-games.i386 = bsd-games,i386,0,2.17,21.fc8,fedora
bygfoot.i386 = bygfoot,i386,0,2.2.0,2.fc8,fedora
bzflag.i386 = bzflag,i386,0,2.0.8,8.fc8,fedora
cdogs-sdl.i386 = cdogs-sdl,i386,0,0.4,3.fc8,fedora
celestia.i386 = celestia,i386,0,1.4.1,7.fc7,fedora
cgoban.i386 = cgoban,i386,0,1.9.14,8.fc6,fedora
chess.i386 = chess,i386,0,1.0,10.fc8,fedora
clanbomber.i386 = clanbomber,i386,0,1.05,7.fc8,fedora
coco-coq.noarch = coco-coq,noarch,0,0.1,3.fc8,fedora
crack-attack.i386 = crack-attack,i386,0,1.1.14,10.fc8,fedora
crossfire.i386 = crossfire,i386,0,1.10.0,3.fc8,fedora
crossfire-client.i386 = crossfire-client,i386,0,1.10.0,3.fc8,fedora
crystal-stacker.i386 = crystal-stacker,i386,0,1.5,5.fc8,fedora
csmash.i386 = csmash,i386,0,0.6.6,17,fedora
crystal-stacker-themes.noarch = crystal-stacker-themes,noarch,0,1.0,3.fc8,fedora
cyphesis.i386 = cyphesis,i386,0,0.5.13,2.fc8,fedora
dd2.i386 = dd2,i386,0,0.2.2,2.fc8,fedora
dgae.noarch = dgae,noarch,0,1.1,3.fc8,fedora
duel3.i386 = duel3,i386,0,0.1,0.4.20060225.fc8,fedora
egoboo.i386 = egoboo,i386,0,2.4.3,4.fc8,fedora
enigma.i386 = enigma,i386,0,1.01,3.1,fedora
escape.i386 = escape,i386,0,200704130,6.fc8,fedora
fRaBs.noarch = fRaBs,noarch,0,2.10,3.fc8,fedora
fbg.i386 = fbg,i386,0,0.9.1,1.fc8,fedora
fillets-ng.i386 = fillets-ng,i386,0,0.7.4,3.fc8,fedora
flight-of-the-amazon-queen.noarch =
flight-of-the-amazon-queen,noarch,0,1.0,2.fc8,fedora
flight-of-the-amazon-queen-cd.noarch =
flight-of-the-amazon-queen-cd,noarch,0,1.0,2.fc8,fedora
foobillard.i386 = foobillard,i386,0,3.0a,5,fedora
fortune-mod.i386 = fortune-mod,i386,0,1.99.1,9.fc8,fedora
freeciv.i386 = freeciv,i386,0,2.0.9,4.fc8,fedora
freecol.noarch = freecol,noarch,0,0.7.2,3.fc8,fedora
freedoom.noarch = freedoom,noarch,0,0.5,3.fc8,fedora
freedroidrpg.i386 = freedroidrpg,i386,0,0.10.3,1.fc8,fedora
freedroid.i386 = freedroid,i386,0,1.0.2,8.fc8,fedora
freetennis.i386 = freetennis,i386,0,0.4.8,6.fc7,fedora
frozen-bubble.i386 = frozen-bubble,i386,0,2.1.0,5.fc8,fedora
games-menus.noarch = games-menus,noarch,0,0.2,4.fc8,fedora
gemdropx.i386 = gemdropx,i386,0,0.9,3.fc8,fedora
gl-117.i386 = gl-117,i386,0,1.3.2,4.fc7,fedora
glaxium.i386 = glaxium,i386,0,0.5,2.fc8,fedora
gnubg.i386 = gnubg,i386,0,20061119,13.fc8,fedora
gnugo.i386 = gnugo,i386,0,3.6,5.fc6,fedora
grhino.i386 = grhino,i386,0,0.16.0,2.fc8,fedora
gweled.i386 = gweled,i386,0,0.7,9.1,fedora
hedgewars.i386 = hedgewars,i386,0,0.9.0,3.fc8,fedora
kbilliards.i386 = kbilliards,i386,0,0.8.7b,4.fc8,fedora
kdeedu.i386 = kdeedu,i386,0,3.5.8,3.fc8,fedora
kdegames.i386 = kdegames,i386,6,3.5.8,3.fc8,fedora
ksirk.i386 = ksirk,i386,0,1.7,3.fc8,fedora
ksudoku.i386 = ksudoku,i386,0,0.4,2.fc8,fedora
lacewing.i386 = lacewing,i386,0,1.10,9.fc8,fedora
lincity-ng.i386 = lincity-ng,i386,0,1.1.1,2.fc8,fedora
liquidwar.i386 = liquidwar,i386,0,5.6.3,4.fc8,fedora
lmarbles.i386 = lmarbles,i386,0,1.0.7,8,fedora
londonlaw.noarch = londonlaw,noarch,0,0.2.1,2.fc8,fedora
lucidlife.i386 = lucidlife,i386,0,0.9.2,2.fc8,fedora
machineball.i386 = machineball,i386,0,1.0,4.fc8,fedora
magicor.noarch = magicor,noarch,0,1.0,0.3.rc2.fc8,fedora
manaworld.i386 = manaworld,i386,0,0.0.23,1.fc8,fedora
maniadrive.i386 = maniadrive,i386,0,1.2,4.fc8,fedora
maniadrive-music.noarch = maniadrive-music,noarch,0,1.0,2.fc8,fedora
methane.i386 = methane,i386,0,1.4.7,3.fc8,fedora
mirrormagic.i386 = mirrormagic,i386,0,2.0.2,4.fc8,fedora
monkey-bubble.i386 = monkey-bubble,i386,0,0.4.0,8.fc8,fedora
monsterz.i386 = monsterz,i386,0,0.7.0,8.fc8,fedora
nagi.i386 = nagi,i386,0,2.06,4.fc8,fedora
naturette.noarch = naturette,noarch,0,1.3,1.fc8,fedora
nazghul.i386 = nazghul,i386,0,0.5.6,4.fc8,fedora
nazghul-haxima.i386 = nazghul-haxima,i386,0,0.5.6,4.fc8,fedora
nethack.i386 = nethack,i386,0,3.4.3,15.fc8,fedora
nethack-vultures.i386 = nethack-vultures,i386,0,2.1.0,10.fc8,fedora
netpanzer.i386 = netpanzer,i386,0,0.8.2,1.fc8,fedora
nexuiz.i386 = nexuiz,i386,0,2.3,2.fc8,fedora
njam.i386 = njam,i386,0,1.25,6.fc8,fedora
oneko.i386 = oneko,i386,0,1.2,5.fc8,fedora
openarena.i386 = openarena,i386,0,0.7.1,3.fc8,fedora
openlierox.i386 = openlierox,i386,0,0.57,0.6.beta3.fc8,fedora
overgod.i386 = overgod,i386,0,1.0,6.fc8,fedora
pachi.i386 = pachi,i386,0,1.0,3.fc8,fedora
penguin-command.i386 = penguin-command,i386,0,1.6.11,4.fc8,fedora
pengupop.i386 = pengupop,i386,0,2.2.2,2.fc8,fedora
pinball.i386 = pinball,i386,0,0.3.1,9.fc8,fedora
pingus.i386 = pingus,i386,0,0.7.1,1.fc8,fedora
pipenightdreams.i386 = pipenightdreams,i386,0,0.10.0,7.fc8,fedora
pipepanic.i386 = pipepanic,i386,0,0.1.3,4.fc8,fedora
poker2d.i386 = poker2d,i386,0,1.2.0,1.fc8,fedora
powermanga.i386 = powermanga,i386,0,0.90,1,fedora
ppracer.i386 = ppracer,i386,0,0.3.1,13.fc8,fedora
prboom.i386 = prboom,i386,0,2.4.7,2.fc8,fedora
professor-is-missing.noarch = professor-is-missing,noarch,0,0.1,3.fc8,fedora
qascade.i386 = qascade,i386,0,0.1,8.fc8,fedora
qgo.i386 = qgo,i386,0,1.5.2,1.fc6,fedora
quake3.i386 = quake3,i386,0,1.34,0.3.rc4.fc8,fedora
rafkill.i386 = rafkill,i386,0,1.2.2,5.fc8,fedora
raidem.i386 = raidem,i386,0,0.3.1,7.fc8,fedora
rocksndiamonds.i386 = rocksndiamonds,i386,0,3.2.3,2.fc8.2,fedora
rogue.i386 = rogue,i386,0,5.4.4,1.fc8,fedora
scorched3d.i386 = scorched3d,i386,0,40.1d,6.fc8,fedora
scorchwentbonkers.i386 = scorchwentbonkers,i386,0,1.1,4.fc8,fedora
scummvm.i386 = scummvm,i386,0,0.10.0,2.fc8,fedora
seahorse-adventures.noarch = seahorse-adventures,noarch,0,1.0,2.fc8,fedora
sear.i386 = sear,i386,0,0.6.3,5.fc8,fedora
sergueis-destiny.noarch = sergueis-destiny,noarch,0,1.1,4.fc8,fedora
shippy.i386 = shippy,i386,0,1.3.3.7,6.fc8,fedora
six.i386 = six,i386,0,0.5.3,6.fc8,fedora
slingshot.noarch = slingshot,noarch,0,0.8.1p,1.fc8,fedora
smashteroid.i386 = smashteroid,i386,0,1.11,3.fc8,fedora
solarwolf.noarch = solarwolf,noarch,0,1.5,2.fc8,fedora
sopwith.i386 = sopwith,i386,0,1.7.1,5,fedora
starfighter.i386 = starfighter,i386,0,1.1,11,fedora
stormbaancoureur.i386 = stormbaancoureur,i386,0,1.5.1,2.fc8,fedora
supertux.i386 = supertux,i386,0,0.3.0,1.fc7,fedora
supertuxkart.i386 = supertuxkart,i386,0,0.3,2.fc8,fedora
taxipilot.i386 = taxipilot,i386,0,0.9.2,2.fc8,fedora
tecnoballz.i386 = tecnoballz,i386,0,0.91,6.fc8,fedora
tong.i386 = tong,i386,0,1.0,9.fc8,fedora
torcs.i386 = torcs,i386,0,1.3.0,3.fc8,fedora
trackballs.i386 = trackballs,i386,0,1.1.4,3.fc8,fedora
trackballs-music.noarch = trackballs-music,noarch,0,1.2,4.fc8,fedora
tremulous.i386 = tremulous,i386,0,1.1.0,5.fc8,fedora
tuxpuck.i386 = tuxpuck,i386,0,0.8.2,4.fc8,fedora
ularn.i386 = ularn,i386,0,1.5p4,10.fc8,fedora
uqm.i386 = uqm,i386,0,0.6.2,2.fc8,fedora
vavoom.i386 = vavoom,i386,0,1.24,3.fc8,fedora
vdr-sudoku.i386 = vdr-sudoku,i386,0,0.1.3,2.fc8,fedora
vegastrike.i386 = vegastrike,i386,0,0.4.3,7.fc8,fedora
viruskiller.i386 = viruskiller,i386,0,1.0,6,fedora
warzone2100.i386 = warzone2100,i386,0,2.0.7,5.fc8,fedora
wesnoth.i386 = wesnoth,i386,0,1.2.7,1.fc8,fedora
widelands.i386 = widelands,i386,0,0,0.7.build11.fc8,fedora
worminator.i386 = worminator,i386,0,3.0R2.1,7.fc8,fedora
wormux.i386 = wormux,i386,0,0.7.9,5.fc8,fedora
xaos.i386 = xaos,i386,0,3.2.3,1.fc7,fedora
xarchon.i386 = xarchon,i386,0,0.50,5.fc8,fedora
xblast.i386 = xblast,i386,0,2.10.4,4.fc8,fedora
xgalaxy.i386 = xgalaxy,i386,0,2.0.34,7.fc8,fedora
xboard.i386 = xboard,i386,0,4.2.7,16.fc6,fedora
xmoto.i386 = xmoto,i386,0,0.3.3,2.fc8,fedora
xmoto-edit.i386 = xmoto-edit,i386,0,0.2.4,10.fc8,fedora
xpilot-ng.i386 = xpilot-ng,i386,0,4.7.2,13.fc8,fedora
xpilot-ng-server.i386 = xpilot-ng-server,i386,0,4.7.2,13.fc8,fedora
xplanet.i386 = xplanet,i386,0,1.2.0,2.1.fc8.2,fedora
xscorch.i386 = xscorch,i386,0,0.2.0,12.fc8,fedora
xu4.i386 = xu4,i386,0,1.1,0.2.cvs20070510.fc8,fedora


Should these games not be listed under optional?  Or is the group just an
arbitrary list of packages selected by a committee? 
Comment 4 Scott Glaser 2008-04-14 20:16:02 EDT
BTW, I am not be a pita, just asking the question because this could be
confusing to a new user.
Comment 5 Seth Vidal 2008-04-14 20:46:18 EDT
Actually - I think this might be a difference in how yumex reports the groups.

Tim, can you comment? Is yumex doing something more than expanding out groupinfo?

Comment 6 James Antill 2008-04-14 20:51:05 EDT
 So on a mostly Fed-8 machine I get:

% yum groupinfo 'Games and Entertainment' | wc -l
234

...and the list looks identical to the above (if I pass it through sort ...
fixing upstream).
 So my guess is that you ran the groupinfo command as non-root and didn't have
the group data for Fedora? ... or something else. Did you run the above as root?
What files do you have in /var/cache/yum/*?
Comment 7 Seth Vidal 2008-04-14 21:05:18 EDT
James, do you have livna enabled?

it looks like whatever was merging the groups is not, now for some reason.

I'm only seeing the pkgs from livna's Games and Entertainment group, here, too
Comment 8 Scott Glaser 2008-04-14 21:29:30 EDT
Just so we are all on the same page, when I did the list with yumex I disabled
all other repositories except fedora.  Also I am running a fully up to date
version of F8.
 
Comment 9 Seth Vidal 2008-04-14 23:06:47 EDT
okay - the issue is this

livna has a group named "Games and Entertainment" but with a groupid of
rpmfusion-games.

fedora has a group named "Games and Entertainment" but with a groupid of games

yum is returning the first group matching "Games and Entertainment"

It's always been this way in yum, we just never noticed it b/c the above had not
been the case.

I've got a potential fix for it - but I want to get some other input before I
commit it.

thanks
Comment 10 Tim Lauridsen 2008-04-17 03:49:52 EDT
(In reply to comment #5)
> Actually - I think this might be a difference in how yumex reports the groups.
> 
> Tim, can you comment? Is yumex doing something more than expanding out groupinfo?
> 
> 

No yumex don't do any else than expanding the group info, but it showing group
based on the groupid, not the groupname.
Comment 11 seth vidal 2008-04-17 08:17:51 EDT
yah - and the code I checked into yum 2 days ago closes this bug anyway.

Note You need to log in before you can comment on or make changes to this bug.