This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 442065 - plugin-config AVC, why need execmem? why set-uid root?
plugin-config AVC, why need execmem? why set-uid root?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 11:23 EDT by Charles R. Anderson
Modified: 2008-04-17 08:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 08:10:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2008-04-11 11:23:35 EDT
Description of problem:

Every time I launch a tab from a URL in gnome-terminal, I get this
AVC.  Why does plugin-config need execmem, and why is this program set-uid root?

>ls -l /usr/lib/nspluginwrapper/plugin-config
-rwsr-xr-x 1 root root 60048 2008-03-11 10:02
/usr/lib/nspluginwrapper/plugin-config*

Summary:

SELinux is preventing plugin-config (nsplugin_config_t) "execstack" to <Unknown>
(nsplugin_config_t).

Detailed Description:

SELinux denied access requested by plugin-config. It is not expected that this
access is required by plugin-config and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                unconfined_u:unconfined_r:nsplugin_config_t:s0-s0:
                              c0.c1023
Target Context                unconfined_u:unconfined_r:nsplugin_config_t:s0-s0:
                              c0.c1023
Target Objects                None [ process ]
Source                        plugin-config
Source Path                   /usr/lib/nspluginwrapper/plugin-config
Port                          <Unknown>
Host                          dustpuppy.wpi.edu
Source RPM Packages           nspluginwrapper-0.9.91.5-26.fc9
Target RPM Packages
Policy RPM                    selinux-policy-3.3.1-31.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     dustpuppy.wpi.edu
Platform                      Linux dustpuppy.wpi.edu
                              2.6.25-0.204.rc8.git4.fc9.i686 #1 SMP Mon Apr 7
                              11:33:46 EDT 2008 i686 i686
Alert Count                   14
First Seen                    Tue 08 Apr 2008 03:07:02 PM EDT
Last Seen                     Fri 11 Apr 2008 11:02:14 AM EDT
Local ID                      3be91387-8d68-4700-868a-cc02880ae589
Line Numbers

Raw Audit Messages

host=dustpuppy.wpi.edu type=AVC msg=audit(1207926134.511:4168): avc:  denied  {
execstack } for  pid=30324 comm="plugin-config"
scontext=unconfined_u:unconfined_r:nsplugin_config_t:s0-s0:c0.c1023
tcontext=unconfined_u:unconfined_r:nsplugin_config_t:s0-s0:c0.c1023 tclass=process

host=dustpuppy.wpi.edu type=SYSCALL msg=audit(1207926134.511:4168):
arch=40000003 syscall=125 success=no exit=-13 a0=bff95000 a1=1000 a2=1000007
a3=fffff000 items=0 ppid=30322 pid=30324 auid=10002 uid=10002 gid=10002 euid=0
suid=0 fsuid=0 egid=10002 sgid=10002 fsgid=10002 tty=(none) ses=1
comm="plugin-config" exe="/usr/lib/nspluginwrapper/plugin-config"
subj=unconfined_u:unconfined_r:nsplugin_config_t:s0-s0:c0.c1023 key=(null)

Version-Release number of selected component (if applicable):
nspluginwrapper-0.9.91.5-26.fc9.i386
selinux-policy-3.3.1-31.fc9.noarch

How reproducible:
always

Steps to Reproduce:
1. right click a URL in gnome-terminal, Open Link
Comment 1 Andrew Farris 2008-04-11 17:31:21 EDT
Start removing your plugins until you find out which causes it, most of the time thats due to flash.  You 
can setsebool allow_ns_plugin_execmem=1
Comment 2 Martin Stransky 2008-04-17 08:10:43 EDT
Thanks for the hint. Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.