Bug 442091 - rhn-manager-channel --update-taxonomy doesn't
rhn-manager-channel --update-taxonomy doesn't
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn500
All Linux
low Severity low
: ---
: ---
Assigned To: Bryan Kearney
Stephen Herr
US=21735
:
Depends On:
Blocks: 443075
  Show dependency treegraph
 
Reported: 2008-04-11 13:28 EDT by James Bowes
Modified: 2013-01-10 04:58 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 16:22:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Bowes 2008-04-11 13:28:48 EDT
--update-taxonmy sets the supplied values onto the wrong fields of the taxonomy,
so they aren't updated properly
Comment 1 James Bowes 2008-04-21 08:27:13 EDT
To test:
 * use rhn-manage-channel-internal --read-taxonomy to dump a channel's taxonomy
into a file.
 * edit the file, changing any of the values (except channel label).
 * use rhn-manage-channel-internal --update-taxonomy to update RHN with the new
value.
 * use --read-taxonomy to verify that the value was changed.
Comment 2 Stephen Herr 2008-04-23 11:58:21 EDT
So it looks like everything works *except* for updating. If multiple edits are
made to a channel's taxonomy it will accept them and update everything but the
state.
Comment 3 Stephen Herr 2008-04-24 09:55:26 EDT
verified in dev - looks much better
Comment 4 Amy Owens 2008-06-13 11:28:04 EDT
now I got it to work in qa :)

Note You need to log in before you can comment on or make changes to this bug.