Bug 442094 - qla2xxx driver running I/O causes "Kernel: PCI-DMA Out of SW-IOMMU space" error
qla2xxx driver running I/O causes "Kernel: PCI-DMA Out of SW-IOMMU space" error
Status: CLOSED DUPLICATE of bug 433554
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.2
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 13:38 EDT by Aspi Charna
Modified: 2008-04-18 13:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 12:19:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample of /var/log/messages, output of lspci showing the device in question and output of meminfo (5.23 KB, text/plain)
2008-04-11 13:38 EDT, Aspi Charna
no flags Details

  None (edit)
Description Aspi Charna 2008-04-11 13:38:53 EDT
- Description of problem:

Heavy I/O activity fails. The /var/log/messages shows the following error:

"PCI-DMA: Out of SW-IOMMU space for 65536 bytes at device 0000:0d:00.0"
"printk: 92 messages suppressed"

This is repeated constantly as long as I/O is run.

- Version-Release number of selected component (if applicable):

2.6.18-87.el5xen x86_64

qla2xxx "inbox driver" 8.02.00-K5-rhel5.2-04


- How reproducible:

It is very reproducible. Error occurs every time I/O is run.

- Steps to Reproduce:

1. Attach a Qlogic QLE2562 8G FC Adapter in server. Configure a Multipath    
configuration with EMC storage 
2. Run heavy I/O (large file reads and writes, using Medusa Tools “Pain”)
3. Observe /var/log/messages file
4. The I/O fails with “I/O halt” messages 

  
Actual results:


Expected results:


- Additional info:

similar bug was reported (Bug 219216) and was resolved by an errata kernel in 
Redhat 5.1. 

A sample of /var/log/messages, output of lspci showing the device in question 
and output of meminfo is attached. (IOMMU-ER.txt)
Comment 1 Aspi Charna 2008-04-11 13:38:53 EDT
Created attachment 302151 [details]
sample of /var/log/messages, output of lspci showing the device in question and output of meminfo
Comment 2 Bill Burns 2008-04-11 14:34:42 EDT
This should be fixed in the latest kernel build (-89) which will be in snapshot 5.
In the meantime please try the -89 kernel availble here:
http://people.redhat.com/bburns/kernel-xen-2.6.18-89.el5.x86_64.rpm

Thanks
Comment 3 Bill Burns 2008-04-11 14:36:42 EDT
Probable duplicate of 433554.
Comment 4 Aspi Charna 2008-04-18 11:50:03 EDT
The new Kernel provided (kernel-xen-2.6.18-89.el5.x86_64.rpm) has resolved the 
issue. There are no error messages related to IOMMU in the messages file.
Comment 5 Bill Burns 2008-04-18 12:19:59 EDT

*** This bug has been marked as a duplicate of 433554 ***
Comment 6 Bill Burns 2008-04-18 12:20:28 EDT
Thank! Marked as a duplicate.

Note You need to log in before you can comment on or make changes to this bug.