Bug 4421 - Pump accumulates data in file descriptors
Pump accumulates data in file descriptors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
http://eve.speakeasy.org/~dittrich/pu...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-07 15:11 EDT by dittrich
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-25 00:38:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dittrich 1999-08-07 15:11:25 EDT
I am using pump-0.6.7-2 with kernel-2.2.5-15 and
ipchains-1.3.8-3.  I have a DSL line from USWest, which
has a four hour lease time.  When I first boot the system,
everything works fine.  I tend to use SSH for terminal
sessions to computers at work and another ISP where I
have an account.

After four hours, when DHCP lease time is up and pump
goes to renew the lease, things start to go bad.  The
lease is renewed fine, even keeping the same IP address
for two or more days.  The problems that I see are:

1).  SSH connections begin to randomly disconnect
("connection reset by peer" TCP failure).

2).  When I go to shut the system down, it hangs when
it is trying to run "ifdown eth0".  I have to turn the
system off, which requires an fsck each time I reboot.

I notice that pump, after the four hour lease period,
begins to accumulate bytes in file descriptors 0 and/or
1, wracking up several megabytes in less than a day.
If I kill pump (which closes these file descriptors)
I can get the interface to shut down OK, but not if I
just choose "Shutdown" from the KDE login screen Options
menu.

You can find a copy of my ipchains rules (pertaining to
bootp client/server - these are the least restrictive rules
I have tried, originally using the DHCP server's IP address)
and the output of "date;lsof | pump" (edited down
somewhat to just show when the growth starts, and what
the growth rate is) at:

	http://eve.speakeasy.org/~dittrich/pumpdebug.txt

BTW, I've tried switching back to DHCPCD, and it no longer
works with 6.0 (I was using it before under 5.2, with
the ipchains patches to the 2.0.35 kernel, but that
failed to renew the lease completely).
Comment 1 dittrich 1999-08-07 15:15:59 EDT
Oops. I meant "date; lsof | grep pump"
Comment 2 Michael K. Johnson 1999-09-25 00:38:59 EDT
Update to pump-0.7.0 from the updates directory.  If that does not
fix it, try pump-0.7.2 from the rawhide directory.  If neither fixes
the problem, please reopen this bug with that information.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.